Probleme avec carte SD

Bonjour,

Lorsque je teste l'exemple de la librairie SD, j'ai cette erreur :

Initializing SD card...initialization failed. Things to check:

  • is a card is inserted?
  • Is your wiring correct?
  • did you change the chipSelect pin to match your shield or module?

Que faire ?

Je précise que j'ai bien placé une carte SD fat32 dans le module de carte sd.

Bonjour,

  1. vérifier les 3 points cités
  2. Quelle capacité de la SD ?
    @+

Il y a bien une carte.
les branchements sont bon aussi.

Par contre qu'est-ce que le chipSelect ?

Sinon c'est une carte de 1GB.

Re,
Donne nous le lien vers ta carte pour voir.
Reste que tu n'as pas répondu sur la capacité mémoire de la carte SD car le pb peut également venir de là :wink:

C'est une carte de 1 GB de memoire.
Quelle carte pour le lien ?

J'utilise une arduino uno.

En fait, la carte sd ne doit pas être détectée je pense.

Ce qui est bizarre, c'est qu'il y a 5 mins, elle a été détectée, il y avait un problème de formatage, je l'ai donc formatée et la plus détectée. comme cela ce fait que de temps en temps ça marche et d'autres fois non ? Alors que je ne change ni le code ni rien d'autre que le fait d'enlever la carte puis de la remettre.

bienvenue

quel est l interface utilisée comme lecteur ?
comment sont branchés les liaisons spi ?

j'ai un shield ethernet+lecteur carte et un autre rtc1307+lecteur : test ok avec sd 128 megas 2 et 4 gigas

j'ai un autre uniquement lecteur sdhc format micro : catalex avec level shifter lv125, n'a jamais fonctionné

la gestion du chipselectdans les biblios sd et sdfat est assez nébuleuse