Problème communication IDE-Carte

Bonjour après avoir fait le tour de google du forum Arduino et autres je n'ai toujours pas trouver de solution

Présentation :

PC Windows 7 (32 bit)

logiciel Arduino 1.8.4

message d’erreur :

[code] Arduino : 1.8.4 (Windows 7), Carte : "Arduino/Genuino Uno"

C:\Program Files\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\Arduino\hardware -tools C:\Program Files\Arduino\tools-builder -tools C:\Program Files\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files\Arduino\libraries -libraries C:\Users\Guillaume\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0001 -ide-version=10804 -build-path C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484 -warnings=none -build-cache C:\Users\GUILLA~1\AppData\Local\Temp\arduino_cache_724854 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files\Arduino\hardware\tools\avr -verbose C:\Users\Guillaume\Documents\Arduino\Exemple\Exemple01\Exemple01.ino\Exemple01.ino.ino C:\Program Files\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files\Arduino\hardware -tools C:\Program Files\Arduino\tools-builder -tools C:\Program Files\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files\Arduino\libraries -libraries C:\Users\Guillaume\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0001 -ide-version=10804 -build-path C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484 -warnings=none -build-cache C:\Users\GUILLA~1\AppData\Local\Temp\arduino_cache_724854 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files\Arduino\hardware\tools\avr -verbose C:\Users\Guillaume\Documents\Arduino\Exemple\Exemple01\Exemple01.ino\Exemple01.ino.ino Using board 'uno' from platform in folder: C:\Program Files\Arduino\hardware\arduino\avr Using core 'arduino' from platform in folder: C:\Program Files\Arduino\hardware\arduino\avr Les options de compilation ont été modifiées, tout sera recompilé Detecting libraries used... "C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10804 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR  "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\sketch\Exemple01.ino.ino.cpp" -o "nul" Generating function prototypes... "C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10804 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR  "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\sketch\Exemple01.ino.ino.cpp" -o "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\preproc\ctags_target_for_gcc_minus_e.cpp" "C:\Program Files\Arduino\tools-builder\ctags\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\preproc\ctags_target_for_gcc_minus_e.cpp" Compilation du croquis... "C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10804 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR  "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\sketch\Exemple01.ino.ino.cpp" -o "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\sketch\Exemple01.ino.ino.cpp.o" Compiling libraries... Compiling core... Using precompiled core Linking everything together... "C:\Program Files\Arduino\hardware\tools\avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p  -o "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484/Exemple01.ino.ino.elf" "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484\sketch\Exemple01.ino.ino.cpp.o" "C:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484/..\arduino_cache_724854\core\core_arduino_avr_uno_5638c217b04eda8279099c4937887265.a" "-LC:\Users\GUILLA~1\AppData\Local\Temp\arduino_build_736484" -lm C:\Users\GUILLA~1\AppData\Local\Temp\ccUNZGi3.ltrans0.ltrans.o: In function `main':

C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino/main.cpp:43: undefined reference to `setup'

C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino/main.cpp:46: undefined reference to `loop'

collect2.exe: error: ld returned 1 exit status

exit status 1 Erreur de compilation pour la carte Arduino/Genuino Uno [/code]

ps: la carte est bien alimentée et j'ai le programme de test de l'usine qui fonctionne correctement

il s'agit d'une carte Arduino uno R3 et le seule type de carte qui se rapproche que j'ai trouvé dans l'IDE est "Arduino/Genuino/Uno"

Bonjour,

Les messages d'erreur indiquent que ton programme n'a ni setup() ni loop().

Mets ton programme (entre balises de code)

ok merci kamill

ça marche correctement, la prochaine fois je vérifierait mon programme