Probleme de compilation avec la dernière version 0018

Bonjour,

Je viens de faire la mise à jour Arduino 0018.

  • La compilation d'un programme type ( exemple "Blink" ) ne se fait pas. Message « java.langa;NullpointerExeption suivi de « n » lignes du style « at processing.app.debug.compiler.compile ( compiler.java : 75 » etc.etc.

  • J'ai fait une mise à jour de Java (131 ) qui est activé dans le navigateur Firefox ( après prise en compte de la modification des préférences dans Firefox).

Pas de changement , même problème = pas de compilation...

nota : je suis sous W10 / 64 bits

Merci

Probleme de compilation avec la dernière version 0018

Tu plaisantes ou tu te fiches de nous ?

La version 0.0018 date de plus 5 ans.
La dernière version est 1.8.2.

J'ai fait une mise à jour de Java

Ben oui pour une version d'arduino vielle de plus de 5ans il faut un java vieux de plus de 5 ans et non pas la dernière version.

Bonjour,

  • Non je ne me fiche de personne. On m'avait demandé de jeter un œil à un petit logiciel . fonctionnant sur une carte Arduino ( pilotant un servo de conduite au volant pour handicapé).
    Je ne suis pas du tout familier de ces systèmes et le PC comportait une version encore plus ancienne du logiciel (!). Sans trop réfléchir j'ai télécharge cette version voulant faire vite...La prochaine fois, si il y en a une, j'irais sur le site Arduino.

  • Plates excuses donc mais il est intéressant, en passant, de noter que les 25 personnes qui ont lu le post, à part toi, ne se sont ni formalisées ni étonnées du fait que j'utilisais une version antédiluvienne...

  • Je te remercie donc de ton intervention tout en regrettant le ton peu amène. Je découvre Arduino par la force des choses et pense que le « présumé innocent » sur ce forum devrait être la règle, mais les temps changent, on le voit rien qu'en suivant l'actualité...

nota : j'avais posté par erreur la même question sur le site en anglais dans la rubrique "Troubleshouting etc.": le style de la réponse me convient mieux, tout n'est pas perdu dans le monde anglo-saxons semble t-il .

bonjour,

  • Plates excuses donc mais il est intéressant, en passant, de noter que les 25 personnes qui ont lu le post, à part toi, ne se sont ni formalisées ni étonnées du fait que j'utilisais une version antédiluvienne...

simplement, qu'a partir du moment où un membre "ancien" du forum réponde à un post, il est de mise de ne pas renchérir sur lui pour dire la même chose :wink:

  • Je te remercie donc de ton intervention tout en regrettant le ton peu amène. Je découvre Arduino par la force des choses et pense que le « présumé innocent » sur ce forum devrait être la règle, mais les temps changent, on le voit rien qu'en suivant l'actualité...

l'époque des exams et des questions niaises étant de mise ces derniers temps, avec le peu de recherches de certains nous amène a répondre parfois de manière un peu sèche.
Vu ta question et les références citées, cela porte à confusion, d'où la réponse de 68tjs qui est au demeurant très sympa.

je pensais a une faute de frappe ou d'inattention et que Mr samanu avait chargé la version 1.8.x

Samanu:
Bonjour,

Je viens de faire la mise à jour Arduino 0018.

nota : je suis sous W10 / 64 bits

Merci