Problème de téléversement marlin arduino 2560

Bonjour,

Pour commencer voici ma config :

Arduino méga 2560 AT R3 Arduino 1.6.9 Marlin 1.1.0 RC6

Win Vista (auparavant Win7)

Lorsque je téléverse marlin vers l'arduino j'ai un message d'erreur qui apparait après la compilation :

Le croquis utilise 51 188 octets (20%) de l'espace de stockage de programmes. Le maximum est de 253 952 octets. Les variables globales utilisent 2 967 octets (36%) de mémoire dynamique, ce qui laisse 5 225 octets pour les variables locales. Le maximum est de 8 192 octets.

avrdude: ser_open(): can't open device "\.\COM22": Accès refusé. avrdude: ser_drain(): read error: Descripteur non valide Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.

Concernant le port :

USB SERIAL PORT (COMx) Driver utilisé : CDM v2.12.18 WHQL certified.

Avez vous une idée sur la solution ? Merci

Thibault

thibaultp: Concernant le port :

USB SERIAL PORT (COMx) Driver utilisé : CDM v2.12.18 WHQL certified.

Avez vous une idée sur la solution ? Merci

Thibault

Bonsoir C'est un clone d'arduino mega ? photos ? parce que là ça ressemble à un probleme de driver FTDI

Oui je pense que c'est un clone. En effet je trouve ça surprenant que le port soit usb serial port et non arduino mega 2560. Le fichier utilisé pour le drivers se nomme ftdiport.inf

thibaultp: Oui je pense que c'est un clone. En effet je trouve ça surprenant que le port soit usb serial port et non arduino mega 2560. Le fichier utilisé pour le drivers se nomme ftdiport.inf

Donc tu a voulu utiliser un PC sous vista , alors qu'avant tu utilisais W7 (sans problèmes ) ? Si oui , tu a peut etre un problème résiduel concernant les drivers FTDI lire çà

Non j’avais également des problèmes de drivers avec win 7. Très bien je te remercie je vais regarder ça :wink:

J'ai regardé la vidéo proposée sur le lien mais je ne sais pas comment obtenir le statut FT232R USB UART pour le port. De plus, quand j'essaie d'installer les drivers manuellement, l'installation de FTDI bus (USB serial converter) est correct mais l’installation du FTDI port (USB Serial port) c'est impossible. J'obtiens un erreur (code 10). Mon port est maintenant reconnue en USB Serial port (COM4) avec un panneau orange. Qu'est ce que je peut faire? Faut-il se pencher sur l'erreur code 10 ?merci pour votre aide

Je viens de voir sur un forum que le problème pourrait venir du chipset? CH340G, j'ai donc télécharger les drivers correspondant et mon arduino est maintenant reconnu en USB - SERIAL CH340 (COM5). La vérification sur Marlin est ok. Le téléversement m'annonce un code d'erreur

avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_getsync(): timeout communicating with programmer

Je vais maintenant essayer de voir si mon firmwire est à jour en utilisant un logiciel FLIP. ((rev. 0001) version of the ATmega8U2 firmware since around May, 2011.)

voir forum : https://translate.google.fr/translate?sl=en&tl=fr&js=y&prev=_t&hl=fr&ie=UTF-8&u=https%3A%2F%2Fwww.arduino.cc%2Fen%2FHacking%2FDFUProgramming8U2&edit-text=&act=url

Voici les informations que je récupère :

USB\VID_1A86&PID_7523&REV_0254

Il faut maintenant que je télécharge un firmwire à jour (https://github.com/arduino/Arduino/tree/master/hardware/arduino/avr/firmwares/atmegaxxu2)