Problème de transfert entre Arduino IDE et imprimante 3D sur mac

Bonjour à tous.

Pour faire simple, j’ai acquis une imprimante 3D il y a quelques temps et je souhaite remplacer son système d’exploitation par un autre plus personnalisable. Pour cela je dois le transférer dans la carte de l’imprimante via le logiciel Arduino IDE. Quand je le fais, voici ce qu’Arduino IDE indique comme message d’erreur :

avrdude: Version 6.3-20171130​
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch


System wide configuration file is “/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf”
User configuration file is “/Users/Arnaud/.avrduderc”
User configuration file does not exist or is not a regular file, skipping​

Using Port : /dev/cu.wchusbserial410
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd6
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x80
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xbf
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xae
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xd6
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x02
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x21
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xcc
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xd6​

avrdude done. Thank you.

Une erreur est survenue lors du transfert du croquis​

D’après un forum spécialisé sur les imprimantes 3D, le taux de transfert devrait être 115200 au lieu de 57600 (dans le moniteur série d’Arduino IDE, j’ai mis le réglage du taux de transfert à 115200 au lieu de 9600).

Et quand je vais dans le rapport système de mon mac, voici ce que j’ai sur le port USB utilisé pour le transfert :

Ma question est : y a-t-il un moyen de régler le taux de transfert pour atteindre les 115200 ?

Merci d’avance.

2021783842_Capturedecran2019-08-21a09_27_00.png.44d10ed84da7c9e9ce305399ddc202f3.png

Tu parles de la vitesse de transfert du code de l'IDE vers ton arduino ? Regarde ici : la vitesse est définie dans le fichier arduino/hardware/boards.txt (serial.download_rate).

De ce qu'on m'a dit sur le forum spécialisé dans les imprimantes, c'est cette ligne du message d'erreur qui interpelle :

Overriding Baud Rate : 57600

Normalement, je devrait être à 115200.

J'ai donc modifier le fichier boards.txt. Dans ce fichier j'avais ça :

Anet V1 (sanguino clone) -

anet.name=Anet V1.0

anet.upload.tool=arduino:avrdude anet.upload.protocol=arduino anet.upload.maximum_size=126976 anet.upload.speed=57600

anet.bootloader.low_fuses=0xD6 anet.bootloader.high_fuses=0xDA anet.bootloader.extended_fuses=0xFD anet.bootloader.unlock_bits=0x3F anet.bootloader.lock_bits=0x0F

anet.build.mcu=atmega1284p anet.build.f_cpu=16000000L anet.build.board=AVR_SANGUINO anet.build.core=arduino:arduino anet.build.variant=sanguino

anet.bootloader.file=atmega/ATmegaBOOT_168_atmega1284p.hex anet.bootloader.tool=avrdude

J'ai donc changé la ligne anet.upload.speed= en mettant 115200 au lieu de 57600. J'ai donc repris un télétransfert et là ... nouveau message d'erreur

Le suspense est insoutenable... Que dit ce nouveau message d'erreur?

Si c'est la même série

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd6 avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6f

tu as un message épinglé en haut du forum français qui traite ce problème

:D Oups, désolé, j'ai oublié de mettre le nouveau message d'erreur ^^ Le voici :

avrdude: Version 6.3-20171130 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf" User configuration file is "/Users/Arnaud/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.wchusbserial620 Using Programmer : arduino Overriding Baud Rate : 115200 avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x49 avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6e avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x66 avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x6f avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x3a avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x45 avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x78 avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x74 avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x65 avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x72

avrdude done. Thank you.

Une erreur est survenue lors du transfert du croquis

Vu que les fins de lignes ne sont pas les mêmes que le précédent message, je pense pas que ce soit la même série du coup ?

Va quand même voir ce sujet https://forum.arduino.cc/index.php?topic=574627.0

J’ai lu le poste mais rien n’y fait. Tout à l’air correct d’après ce qui y est dit. Pour info, j’ai suivi ce tutoriel au départ pour faire l’installation dont je vous met un extrait en pièce jointe.

TUTO - Installer Marlin 1.1.9 avec BLTouch sur Anet A6 ou A8.pdf (2 MB)

Bonjour ,

Je vois :

User configuration file does not exist or is not a regular file, skipping

dans le message d'erreur.

Quid?

Cordialement, bidouilleelec