Problème incompréhensible avec la lecture de librairies

Bonjour à tous,

Je suis actuellement sur un projet pour les cours qui a été grandement fait là bas.
J'ai quand même voulu avancer dessus chez moi.
Le problème c'est que certaines librairies ne veulent pas du tout être reconnue.

J'ai tout essayé depuis hier, j'ai testé différentes versions de l'IDE, différentes versions des librairies, rien n'y fait. Le nom du dossier est identique au .h et au .cpp
A savoir que tout fonctionne en cours, c'est bien un soucis au niveau de la lecture des librairies puisque les 2 en question ne s'affiche pas en orange comme les autres.

Problème de compil du coup:

Le code: http://pastebin.com/U7bxuVcy

Si quelqu'un a la moindre idée n'hésitez pas.

Les librairies ont-elles été installées dans le bon répertoire?
Est-ce qu'elles apparaissent dans le menu déroulant Croquis/Importer bibliothèque?
Est-ce que les programmes d'exemple associés aux librairies apparaissent dans le menu Fichier/Exemples
Si ce n'est pas le cas alors soit:

  • les librairies ne sont pas installées au bon endroit
  • les librairies ne sont pas reconnues (problème de nom de fichier par exemple)

fdufnews:
Les librairies ont-elles été installées dans le bon répertoire?

Oui avec celles de base:


J'ai réussi à faire fonctionner la DS3231, malheureusement DallasTemperature n'est toujours pas reconnue.

Je ne sais pas pourquoi la librairie n'est pas reconnue.
En tout cas, en important le .cpp et le .h dans le répertoire où est situé un sketch qui fait appel à DallasTemperature j'arrive à compiler le code sans erreur. Donc la librairie compile bien.