Problème installation librairies arduino

Bonjour,

je travail sur mon mac et j’ai la dernière version de l’ide d’arduino. Je dois envoyer des données via Radio fréquence, je me suis donc muni de deux cartes arduino et deux deux modules Nrf24l01+.

J’ai suivit les tutoriels pour installer les librairie requise à savoir Mirf MirfhardwareSpiDriver et Nrf24l01.

J’ai télécharger les fichiers à partir du lien suivant:

Et je les est installé comme suit: je suis allé dans l’ide d’arduino j’ai cliqué sur croquis et j’ai ajouté le dossier contenant les fichiers (jai donc ajouté trois dossier: un portant le nom de Mirf dans lequel j’ai mis le .cpp et le .h fournit sur github, ainsi de suite ).

Jusque la tout vas bien ( mais j’ai certainement déja du faire une erreur dans la procédure que j’ai suivit), en effet, lorsque je compile mon code (code faisant appelle au fonction déclarer dans mes librairies ajouté ) il me dis qu’il ne connais pas de fonction mirf.

Que dois je faire? j’ai certainement mal installé mes librairies que me conseillerais vous?

Navrer du dérangement, et merci de vos réponses.

Cordialement.

Salut, tu dois installer tes fichiers dans le dossier librairie

Bonjour,

Tu télécharges le zip sur cette page (bouton clode or download)
Tu ajoutes la librairie avec l'ide arduino -> Croquis/Include Library/Add .zip library

Et il ne faut pas dé-zipper, l'IDE s'en débrouille

Ok je vais essayer avec le .zip parce que effectivement pour les autres fichiers je les avait coller dans le fichier librairies et j'avais aussi essayer de les installé depuis l'ide mais sa revenais au meme ( l'ide les copier automatiquement dans le fichier librairie)

Je me demandais si c'est pas parce quelle était trop vielle par rapport a ma version de arduino?

Je vais tester le zip merci

Qand je download le zip et que je fais "Croquis/Include Library/Add .zip library" j'ai le message d'erreur suivant:

""
Arduino : 1.6.11 (Mac OS X), Carte : "Arduino/Genuino Uno"

Le dossier spécifié ne contiens pas de bibliothèque valide

Ce rapport pourrait être plus détaillé avec
l'option "Afficher les résultats détaillés de la compilation"
activée dans Fichier -> Préférences.

""
Je sais pas si je peux les utiliser pouvez vous essayer de les installé sur votre ide et me dire si cela marche?

Merci

Si ça ne fonctionne pas avec le zip, tu ouvres le zip, à l'intérieur il y a un répertoire arduino-nrf24l01-master, tu l'ouvres aussi et tu drag and drop le répertoire Mirf dans le répertoire Arduino\libraries (comme je suis sous windows, je ne connais pas le chemin complet sous mac)

ok ok je vais tenter mais je ne suis pas convaincu que cela marchera, dans le gestionnaire des biblihotèques apparaissent seulement les nouvelles bibli liée au module nrf24l01+ a savoir RF24 RF24network Rf24mirf etc.. je me demande si vu que ce sont d"es fichier de 2014 et ceux que j'essaye d'utiliser de 2011 peut etre les ont il remplacé et on ne peux plus les utilisé, mais en meme temps chaque personne peut créer sa propre biblihotèque donc je vois pas pourquoi je ne pourrais pas en utiliser une vielle !

Je vais essayer je vous tiens au courant merci pour les astuces en tout cas.

Elle marche chez vous ?

Oh le génie !! Sa marche :slight_smile: haha en fait j'aurais pas du les exploser en sous fichier !! Merci Kamil vous m'enlevez une belle épine du pied !