Problème: mcp79410 i2c rtc

Bonjour, j ai un problème l horloge mcp 79410 perd 10 secondes toute les minutes par rapport à une horloge de référence. Je cite aussi que j ai un pwrfail dans le registre 0x03. Merci de vos réponses

Bonjour

  1. Qualité du quartz ?

  2. Bon choix des condensateurs Cx1 et Cx2 ?
    oscillateur.jpg

  3. Bon usage du registre OSCTRIM ? (data sheet page 30 )
    (Voir également la calibration page 31)

  4. Pourquoi avoir choisi cette référence de RTC et non une référence comme DS2331 , couramment utilisée sur ce forum avec succès avec les librairies éprouvées ?

oscillateur.jpg

remycr:
Je cite aussi que j ai un pwrfail dans le registre 0x03. Merci de vos réponses

Ce fonctionnement est normal. Le bit est levé lorsque l'alimentation principale de la RTC tombe. Donc à chaque extinction de ton système ce bit est levé.
A charge pour le logiciel de l'effacer.

Bonjour, si j ai utilisé cette horloge c est car celle-ci est déjà présente sur le shield que j ai acheté et le montage n est donc pas le mien

Bonjour, alors comment réglé le registre correspondant à la configuration adresse hexa 0x07 correctement ? Merci

Bonjour

le registre d'adresse 0x07 est présenté à la [page 27 de la Notice technique ](http://"Smart | Connected | Secure | Microchip Technology I2C-RTCC-20002266J.pdf")... et il faut se farcir tout le chapître 5.6 "Digital Trimming" pour compléter la configuration :o

faire le "défrichage" c'est le prix à payer quand on sort des sentiers battus.....