probleme mit attiny84 und virtual wire

hallo,

ich würde gerne den attiny als 433mhz sender nutzen, doch leider klappt es nicht.

ich habe die aktuelle virtual wire (1.27) und habe auch shcon andere ausprobiert.

ich habe zwei verschiedenen libarys für den attiny ausprobiert und auf dem arduino läuft der sketch.

ich würde zu testzwecken gerne diesen sketch aufspielen bzw verwenden:

"

#include <VirtualWire.h>

const int rxPin = 2;
const int ledPin = 1;

char *message;

void setup()
{
pinMode(ledPin, OUTPUT);

vw_set_ptt_inverted(true);
vw_setup(2000);
vw_set_tx_pin(rxPin);
}

void loop()
{
digitalWrite(1, LOW);
message = “OFF”;
vw_send((uint8_t *)message, strlen(message));

delay (1000);
digitalWrite(1, HIGH);
message = “ON”;
vw_send((uint8_t *)message, strlen(message));
delay (1000);
}

"

wenn ich “vw_setup(2000);” und “vw_send((uint8_t *)message, strlen(message));” rausnehme, läuft er auf dem aatiny aber dann kann ich halt nichts senden (;

laut der virtual wire seite soll virtual wire attiny84 unterstützen…

Hallo, ich verwende ATtiny 85/4313, kann daher nur theoretische Vermutungen anstellen:

hi,

ja, läuft mit 8mhz internal.

das vw_wait wartet doch nur, bis gesendet ist ?

stimmt ! ist echt etwas seltsam 8hatte das so übernommen, aus dem beispiel (:wink:
sollte aber keien rolle spielen, initialisiert wird ja der tx-pin bzw rxPin ist nur eine variable....

und auf dem arduino lief das ja.....

kennt denn wer eine alternative zur virtual wire ?

RC-Switch läuft jedenfalls ohne probleme auf dem attiny.
und radiohead fand ich etwas komisch bzw nimmt extrem viel speicherplatz ein.....