Probleme mit Compiler

Hallo,

ich arbeite immer noch mit der 1.0.6 unter OpenSuse 13.2.

Irgendwann in den letzten zwei Wochen habe ich mir ein Update auf einen neuen
AVR-Crosscompiler eingefangen. Und seit dem meldet die IDE nach dem Kompilieren
immer "as unkonwn option mmcu=avr5.

Im Prinzip weiß ich was schief läuft. Die IDE ruft den normalen AS auf und nicht den
AVR-AS. Aber warum ?

Da ich auf einem anderen Rechner noch einen alten Crosscompiler hatte habe ich
die Binaries einfach rübergespielt. Aber das nutzt nichts. Es wird immer noch der falsche
AS aufgerufen. Ich habe dann einfach mal den AVR-AS nach AS unbenannt. Dann bekomme
ich aber nur noch "permission denied".

Ich denke das da irgendwelche Links verbogen sind, aber welche und wo ?

Ulli

Ich antworte gleich mal selber.
Was da wo verbogen wurde habe ich nicht herausgefunden, aber ich habe für mich eine Lösung.
Die Arduinoversion von Suse ist so modifiziert das sie ohne Compiler installiert wird.
Sie benutzt eine AVR-Cross installation des Betriebssystems.
Ich habe mir einfach noch mal eine 1.0.6 von hier runtergeladen die mit eigenem Compiler
kommt und die läuft sofort wieder auch wenn Suse noch den "falschen" Compiler hat

Ich könnte ja auch mal auf eine neue IDE updaten, aber schon der Versuch hat mir gezeigt :
Viele Libs gehen nicht (auf Anhieb). Mein mit Mühe installierter 1284,644 und Tiny-Support
läuft nicht auf Anhieb. Auf das ganze Theater habe ich erst mal keine Lust.
Da bleibe ich erst mal bei der 1.0.6 .

Ulli

Hab Deine Posts abgespalten weil sie nichts mit FAQ zu tun haben.
Grüße Uwe