Probleme mit Spannungsversorgung Arduino UNO, entstören?

Hallo Arduino Freunde!

Steure mit einem Arduino UNO einen Servomotortreiber,
habe aber das Problem das der UNO Zeitweise immer wieder "abstürtzt"
und zwar immer wenn irgentwo in dem selben raum ein anderes Gerät eingeschaltet wird,
egal ob Bohrmaschine oder Kompressor, sofort "stoppt" der Arduino und lässt sich nur durch kurzes trennen vom Strom wieder starten.

Habe nun auf ein 5V Netzteil mit 5A umgerüstet, was aber keine Verbesserung brachte.

Hat jemand ähnliches erlebt? oder villeicht eine mögliche lösung dieses Problems? :confused:

Würde mich über Antworten freuen.

MFG Stefan

Schaltplan, wie du das Netzteil angeschlossen hast. Wo sind die Kabel verlegt, welches Netzteil, Entstörfilter vorgeschaltet, Pufferkondensator am Netzteil, ....

Normalerweise sind die Arduinos sehr störunempfindlich. Allerdings wenn die Eingangspins nicht richtig beschaltet sind (Pullups fehlen), dann sind die Eingänge reine Empfänger für Störimpulse.

Danke für die Antworten!

Habe alle Eingänge mit pullup beschaltet, das Netzteil habe ich aus dem EBay

(Schaltnetzteil Netzteil alle Modelle Trafo LED Strip Power Supply | eBay)

und direkt mit gnd und 5V Pin vom Arduino verbunden. Entstörfilter habe ich keinen, kann mir jemand sagen
wo ich sowas herbekomme? Ich denke das ein Kondensator nicht viel bringt da das netzteil nach dem ausstecken den Arduino noch ca 4 sec. betreibt, oder liege ich hier falsch?

Je nach Länge der Verbindungskabel an der Betriebsspannung kann ein Kondensator direkt am Uno schon was bringen. Aber ich befürchte es liegt ein anderes Problem vor. Mach doch bitte mal ein Foto vom Aufbau und möglichst auch ein Schaltbild, dann sehen wir mehr.

Hallo!

Hier ein Bild von dem aktuellen “Aufbau” Links das 36v Netzteil für den schrittmotor treiber, in der Mitte unten “hängt” das 5 v Netzteil für den arduino.

Habe leider keinen Schaltplan, angeschlossen sind einige Taster als Eingang mit aktiviertem pullup. Auserdem in Ausgang auf das ssr -siehe Bild und 2 Ausgänge auf den Schrittmotortreiber.

@ HotSystems

Hast du eine Idee?

Bild

Bild

stefan3000:
@ HotSystems

Hast du eine Idee?

  1. Möglichst den Arduino an einen anderen Platz setzen.
  2. Kabel so verlegen, dass diese nicht in der Nähe des Ardus verlaufen.
  3. Alle Eingänge mit zusätzlichen Pullup (47k) versehen.
  4. Einen Elko (2200 µF) an die Spannungsversorgung direkt am Ardu einbauen.

Das sieht mir so sehr störanfällig aus.

@HotSystems

Danke! werde das nächste woche in Angriff nehmen,
und dann berichten!

MfG

Stefan

@HotSystems

Vielen dank für die Tips!!! jetzt läuft der Arduino, einzig wenn das Licht eingeschatet wird (Leuchtstoffröhren mit Starter)
stoppt er noch.
Kann das daran liegen das ich nur einen 2000µF Kondensator vorgeschaltet habe?

stefan3000:
@HotSystems

Vielen dank für die Tips!!! jetzt läuft der Arduino, einzig wenn das Licht eingeschatet wird (Leuchtstoffröhren mit Starter)
stoppt er noch.
Kann das daran liegen das ich nur einen 2000µF Kondensator vorgeschaltet habe?

Nein, mit dem Elko allein hat das nicht zu tun.
Du solltest die Pullups dann kleiner machen von 47k > 10k.
Da kommen immer noch zu viele Störungen rein.
Hast du die Kabel an den Eingängen auch kürzer gemacht und den Arduino weg von 230 V gebaut?

@HotSystems
Ja Habe den Arduino in eine extra box gesetzt in der nur er ist, ca 1 meter von dem Schatschrank weg in dem die ganzen Netzteile sind.
Die Taster habe ich direkt auf die Box gesetzt auser der Start Taster der hat 1 m Kabel vill liegt es an ihm.
Ich werde das mit kleineren pullups versuchen, ist aber schon deutlich besser geworden, vielen dank für deine Hilfe !

stefan3000:
@HotSystems
Ja Habe den Arduino in eine extra box gesetzt in der nur er ist, ca 1 meter von dem Schatschrank weg in dem die ganzen Netzteile sind.
Die Taster habe ich direkt auf die Box gesetzt auser der Start Taster der hat 1 m Kabel vill liegt es an ihm.
Ich werde das mit kleineren pullups versuchen, ist aber schon deutlich besser geworden, vielen dank für deine Hilfe !

Ja, 1 Meter Kabel ist schon eine sehr gute Antenne für Störungen, da wird es mit den kleineren Pullups sicher besser.
Wenn nicht, könnte ein Kondensator (100 nF gegen GND) an dem Pin auch noch was bringen.