Problème première programmation

Bonjour à tous,

Je suis nouveau dans le monde de la programmation, et mon anniversaire tout récent m’a valu le starter kit ARDUINO. Je m’éclate comme un dingue mais ça ne marche pas, je fais le projet 2 du starter kit mais j’ai un message d’erreur par rapport à l’instruction else que voici "exit status 1 expected unqualified-id defore ‘else’. Voici mon code :

int switchState = 0;
void setup() {
pinMode (3 , OUTPUT);
pinMode (4 , OUTPUT);
pinMode (5 , OUTPUT);
pinMode (2 , INPUT);
}
void loop() {
switchState = digitalRead(2);

if (switchState == LOW)

digitalWrite (3, HIGH);
digitalWrite (4, LOW);
digitalWrite (5, LOW);
}
else{
digitalWrite (3, LOW);
digitalWrite (4, LOW);
digitalWrite (5, HIGH);
delay (250);
digitalWrite (4, HIGH);
digitalWrite (5, LOW);
delay (250);
}
}

Merci d’avance :slight_smile:

Bonjour,

Mets ton code entre balises

Il manque un { après le if et un } à la fin

int switchState = 0;
void setup() {
  pinMode (3 , OUTPUT);
  pinMode (4 , OUTPUT);
  pinMode (5 , OUTPUT);
  pinMode (2 , INPUT);
}
void loop() {
  switchState = digitalRead(2);

  if (switchState == LOW)
  {

    digitalWrite (3, HIGH);
    digitalWrite (4, LOW);
    digitalWrite (5, LOW);
  }
  else {
    digitalWrite (3, LOW);
    digitalWrite (4, LOW);
    digitalWrite (5, HIGH);
    delay (250);
    digitalWrite (4, HIGH);
    digitalWrite (5, LOW);
    delay (250);
  }
}

Formates ton code avec CTRL T pour voir ce genre de problèmes.

SUPER merci beaucoup