Problème RFID 125Hz

Bonjour je fait appelle a vous car je rencontre un problème sur mon lecteur de badge RFID 125 Hz.

( Lecteur RFID Grove 125 kHz 113020002 - Communication | GO TRONIC )

Hier je testais mes programmes qui fonctionner d’habitude et d’un seule coup le lecteur n’a plus voulu fonctionner et une led rouge apparait en permanence sur le lecteur( normalement une led verte clignote à la détection d’un badge). Je me suis renseigné et sur d’autre modèle il suffit d’envoyer un programme vide pour “reset” celui-ci, sur le mien cela ne fonctionne pas . ( Mes programmes marchaient jusqu’à présent …)

Je vous met mon programme

#include <RFID125.h>
#include <SoftwareSerial.h>
RFID125 monRFID;
int solenoidePin = 6;




void setup()
{
  monRFID.brancher(8,9);
  monRFID.ecrireCode("7147179");
  

  
}

void loop()
{
  if (monRFID.testerCode(monRFID.lireCode()))
  {
    digitalWrite( solenoidePin, HIGH );
    delay(10000);
  }
  else
  {
   digitalWrite( solenoidePin, LOW );
  }
}

( J’utilise une bibliothèque spécifique au capteur )

Merci pour vos réponses ( c’est pour mon projet de bac )

quand "ça marchait avant" et "ça ne marche plus maintenant" la question à se poser c'est qu'est-ce qu'on a fait entre temps ?

donnez un lien (clickable) vers votre librairie

c'est supposé faire quoi   solenoidePin( 6 , OUTPUT);

J’ai une gâche électrique qui se commande très simplement c’est a dire qu’il suffit d’envoyer du courant avec un digitalwrite pour quel fonctionne

int solenoidePin = 6; est censé dire sur quel port la gâche est brancher ( j’utilise des modules grove )

vous vous moquez du monde en éditant votre code et en enlevant la ligne en question?

bye

Excusez moi cela n'arrivera plus je n'avais pas mis le bon code toute mes excuses mais se n'est pas le code qui créer l'erreur car meme si l'on prend celui - ci :

http://wiki.seeedstudio.com/Grove-125KHz_RFID_Reader/

celui du site officiel qui est censé fonctionner il ne marche pas