[Problème] Tension de sortie 4.2V

Bonjour,

Je m'excuse par avance si le problème a déjà été évoqué, je n'ai pas trouvé de topic similaire.

J'utilise un arduino nano v3, branché par USB sur ordinateur.

Mon problème est le suivant :

Lorsque je mesure directement la tension entre la pin 27 (5V) et la pin 29 (GND), j'obtiens une tension de 4.2V. Or, j'ai besoin d'une tension entre 4.5 et 5.5V pour alimenter et communiquer avec mon capteur linéaire CCD...

Il me semble que c'était la même chose pour les pin numérique mises en sortie à 1.

Pensez-vous que c'est mon arduino qui a été endommagé, ou alors que mon ordinateur ne fourni pas suffisamment de courant ?

Y aurait-il moyen de d'augmenter la tension sans utiliser un alimentation extérieur ?

Par avance, je vous remercie :smiley: .

Salut,

Rien d'anormal : la chute de tension induite par la diode peut la faire tomber à ces valeurs. Nano officielle ?

bonsoir
nano officielle ?
sur certains clones ont peu trouver de la diode basique qui introduit une chute de tension de ~ 0.7V , pas de la MBR05 qui introduit une chute de tension de de 0.4V ~
test à faire : mesurer la tension en entrée d'usb (V usb ordinateur) et derriere la diode (ce qui est fait semble til avec ta mesure à 4.2V ?

edit : B@tto a degainé plus vite :grin:

Si la carte ne doit être branchée que sur l’USB un petit strap soudé pour court-circuiter la diode et ça roule même pas besoin de la retirer.
Et quand on veut retrouver la diode un coup de pince coupante.

J'avais en effet une LED rouge (assez éblouissante) allumée lorsque j'ai fait mes mesures de tension.

Je ne sais pas du tout si c'est un nano officiel. Je l'ai acheté sur Ebay à un professionnel Chinois... Il ressemble comme deux goutte d'eau au "vrai".

Merci pour vos réponses, je vais essayer vos suggestions.
Si je comprends bien, impossible d'éteindre la LED à l'aide d'un programme ?

Eh il y a confusion sur la diode.

Une diode c'est un composant qui ne laisse passer le courant que dans un seul sens.
Les diodes qui éclairent ne sont que des cas particuliers.

La diode dont parle Artouste est une diode dont le role est d'empécher d'envoyer du courant dans l'USB de ton PC quand la carte nano est alimentée par l'entrée RAW (9V puis régulateur 5V).
Le schéma de la carte peut être téléchargé à partir du site arduino.

Parmis les nombreux types de diode de signal ( c'est à dire pour l'électronique et qui ne s'éclairent pas) il existe des grands classiques :

  • les "normales" qui présentent une chute de tension de 0,7 à 0,8 V.
  • les "Schotky" qui présentent une chute de tension de seulement 0,3 à 0,4 V.
    C'est normalement ce dernier type de diode qui est monté dans une Nano.
    Mais comme elles sont plus chères que font les petits chinois ?

Quand à la diode "électroluminescente' dite DEL (ou LED en anglais) qui brille fort elle sert juste à te dire que la carte est alimentée, c'est à dire à pas grand chose d'utile à part consommer du courant pour rien.

bonjour
oui attention à ne pas tout melanger :grin:
la diode de selection est ici

Oula, je n'ai pas du tout la même disposition de mes composants.

J'ai un composant qui ressemble à cette diode, mais il y a écrit "S4" dessus.

Je vous envoie une photo rapidement avant de reprendre les cours : http://imageshack.com/a/img910/4048/4aCyTo.jpg

Githyanki:
Or, j'ai besoin d'une tension entre 4.5 et 5.5V pour alimenter et communiquer avec mon capteur linéaire CCD...

......

Y aurait-il moyen de d'augmenter la tension sans utiliser un alimentation extérieur ?

Le simple fait de vouloir utiliser un CCD devrait t'inciter à utiliser une alimentation extérieure. Ce genre de capteur est très sensible à la qualité des signaux de commande et à son alimentation. Si tu veux récupérer une "image" de bonne qualité tu devrais partir d'une alimentation très propre.

Je n'ai pas précisé, c'est un capteur linéaire CCD.
Peut être que cela demande moins de précision qu'un CCD "classique" en terme de qualité de signal ?

Sur la datasheet de mon capteur (ILX554B), ils précisent bien que la tension peut être comprise entre 4.5 et 5.5 V, que ce soit l'alimentation ou les signaux.

J'insère l'image ;
je fais les mesures de tension demain pour Vusb ordinateur.
Pour ce qui est soudure j'attends votre confirmation.

Je vous remercie :slight_smile:

Comme c’est moi qui ait parlé de soudure je précise :

Demande :
Tu cherche une solution pour avoir un Vcc de 5V branché sur l’USB d’un PC.
Ma proposition :
Si la carte ne sera jamais simultanément branchée sur l’USB et alimentée par l’entrée raw (12V-9V) alors et dans ce cas seulement tu peux court-circuiter la diode.
Mais dans tous les cas tu n’auras pas mieux que ce que dit la norme USB : 5V +/- 5% et j’ai déjà vu un PC ne délivrer que 4,5V sur l’USB donc il faut encore que ton PC respecte la norme.

Réserves d’usage :
Tu es et restera le seul responsable si tu oublies que la diode est court-circuitée.

Githyanki:
J'insère l'image ;
je fais les mesures de tension demain pour Vusb ordinateur.
Pour ce qui est soudure j'attends votre confirmation.

Je vous remercie :slight_smile:

au moins ça confirme que ce n'est pas une production officielle "arduino" ,
encore qu'aujourd'hui , determiner ce que est un produit officiel arduino avec la "guerre des chefs" n'est pas ce qu'il y a de plus évident :grin:

commence par le plus simple test , mesure avant et apres la diode de selection
apres tu avisera en fonction des conseils

J’ai mesuré à nouveau la tension entre la pin 27 (5V) et la pin 29 (GND) : 3.9V
Du côté de la diode, en me plaçant directement dessus, j’ai une tension de 1.1V.

A un moment, j’ai fais une petite bêtise… je suis passé de voltmètre à ampèremètre entre le 5V et la terre.
Ça a senti le grillé, puis mes tensions sont devenues : 27-29 : 4.5V // diode : 0.5V

5 minutes après, les tension sont repassé à 3.9V / 1.1V

J'ai court-circuité la diode et je suis maintenant à 5V tout pile.
Au final, l'arduino "chinois" me permettra de faire les tests en attendant que je commande un officiel, pour le rendu de mon projet.

Problème résolu, je vous remercie !