problemi comandi AT

Salve, avrei un problema con i comandi AT del modulo hc-05, mi spiego meglio, ho fatto questo piccolo programma , non da errori di sintassi, ma quando voglio comunicare con il modulo tramite il monitor seriale questo non mi invia nessun messaggio di risposta anche se il modulo è in at-mode. Perchè questa cosa?? di seguito vi lascio il programma spero possiate aiutarmi. Grazie
#include <SoftwareSerial.h>

SoftwareSerial BTSerial(5,6); // RX | TX
char A,B;

void setup()
{
pinMode(9, OUTPUT); // this pin will pull the HC-05 pin 34 (key pin) HIGH to switch module to AT mode
digitalWrite(9, HIGH);
Serial.begin(38400);
Serial.println(“Enter AT commands:”);
BTSerial.begin(38400); // HC-05 default speed in AT command more

}

void loop()
{

// Keep reading from HC-05 and send to Arduino Serial Monitor
if (BTSerial.available())
{ B=BTSerial.read();
//Serial.write(“BT:\n”);
Serial.write(B); }

// Keep reading from Arduino Serial Monitor and send to HC-05
if (Serial.available())
{

//BTSerial.println(“AT+ADDR”);
A=Serial.read();
BTSerial.write(A);
BTSerial.println(“AT+STATE”);
}
}

Benvenuto. Essendo il tuo primo post, nel rispetto del regolamento, ti chiediamo cortesemente di presentarti QUI (spiegando bene quali conoscenze hai di elettronica e di programmazione … possibilmente evitando di scrivere solo una riga di saluto) e di leggere con attenzione il su citato REGOLAMENTO… Grazie.
Qui una serie di link utili, non inerenti al tuo problema:

Il codice DEVI racchiuderlo nei tag code, vedi sezione 7 del regolamento, spiega bene come fare ( pulsante </> ).
Altrimenti parte del codice può essere visualizzata male o mancare perchè interpretato come attributo del testo stesso.

>robin456: come ti ha già detto nid69ite qui sopra, ti ricordo che in conformità al regolamento, punto 7, devi editare il tuo post (quindi NON scrivendo un nuovo post, ma utilizzando il bottone More → Modify che si trova in basso a destra del tuo post) e racchiudere il codice all’interno dei tag CODE (… sono quelli che in edit inserisce il bottone con icona fatta così: </>, tutto a sinistra).

In pratica, tutto il tuo codice dovrà trovarsi racchiuso tra due tag: [code] _il _tuo_ codice_ [/code] così da non venire interpretato e non dare adito alla formazione di caratteri indesiderati o cattiva formattazione del testo. Grazie. :slight_smile:

Guglielmo