Problemi con alimentazione arduino!

Buon giorno tutti. Ora ho un grossissimo problema con l'alimentazione della mia scheda Arduino! Per alimentarlo ho collegato un trasformatore nella presa jack che da come output 12 V 2,5 Amp. Dopo dieci minuti si è bruciato il componente sul lato sx del jack.(E' un transistor?). Domanda: Perchè?? Difetto della scheda o alimentatore errato?????? PS: Considerate che la scheda Arduino, se alimentata con usb funziona ancora correttamente! XD.

Cosa intendi per trasformatore? Un alimentatore o proprio un trasformatore? Insomma... lo hai alimentato in alternata o in continua? Nel secondo caso, era stabilizzato e di buona qualità o era una cinesata che ti butta fuori 18 V ?

non è un transistor, ma un regolatore di tensione , se è bruciato, devi averla combinata abbastanza grossa XD

Diciamo che ho "sottratto" un alimentatore ad un apparecchio da laboratorio... (quindi la corrente in uscita dovrebbe essere buona! :) ) . E' un alimentatore da rete (220 input ovviamente) e output mi da 12 V e 2,5 amperes.

Per scrupolo ho testato la corrente in uscita col tester digitale e mi da corrente continua a 12,27 volt...(Che cavolo è successo???booo!!!) :astonished:

dire ho una corrente di 12.3V è un errore, che potrebbe dare confusione (a te e a noi) perche la corene è I la tensione è V...misciare carote e oro non conviene a nessuno!

detto questo, se l'alimentatore da 12.xVcc (continui) è un valore più che buono da mettere nel Jack non si spiega però ancora perche ilr egolatore , a questa tesione, sia saltato.

andando a ipotesi da bar:

  • un brutto corto all'uscita del regolatore
  • una tensione non ideona all'ingresso (come diceva sopra paulus magari alternata anziche continua)
  • regolatore difettoso (raro ma puo succedere)

Mi scuso Martinix se ho usato termini impropri.. putroppo da dilettante non do ancora molto peso ai termini.. :/. Per quanto riguarda la tensione all'uscita dell'alimentatore, a questo punto, credo proprio che non sia essa il problema. Mi viene il sospetto che in fase di test la scheda possa aver cortocircuitato a contatto di qualcosa di metallico... Mi riservo di pensare che il regolatore di tensione fosse difettoso... Sostituirò la scheda con un altra! :-) Grazie a tutti dei consigli ! :-)

tranquillo nessun problema per i termini impropri, solo è bene non confonderli, cosi si capisce meglio anche il problema :)

C'era connessa un po di roba alla scheda di Arduino ?

Il regolatore che si e' bruciato, essendo un lineare, deve dissipare in calore tutta la potenza extra (che e' data dalla differenza fra la tensione di ingresso e quella di uscita, per la corrente richiesta) ... se, ad esempio, la scheda piu qualcosa di collegato avessero richiesto, diciamo, 500mA, il regolatore avrebbe dovuto dissipare in calore (12.3-5)*0.5 = 3.65W ...

Supponendo che tu abbia una UNO (non ce lo dici), che monta un regolatore in case SOT-223, questo tipo di case puo dissipare al massimo meno di 1W, senza area di dissipazione aggiuntiva, che sale a circa 1.5W con un'area di dissipazione di 44mmquadri (tenendo il case a circa 50 gradi) ... il massimo possibile teorico di dissipazione per questo tipo di case, ma con il componente che arriva a 125 gradi :fearful: (di piu no, perche' in teoria a quella temperatura dovrebbe intervenire la protezione termica integrata e spegnerlo) e' un po meno di 3.5W, ma con almeno 1000mmquadri di area di dissipazione ... a quel livello, friggerlo e' un'attimo ...

Mi sono sempre chiesto per quale motivo abbiano usato un case in SOT-223, avendo abbastanza spazio per farci stare comodamente un DPAK, che avrebbe retto e dissipato molto di piu ... mah ...

Comunque, e' chiaro che se ci butti 12V e passa, il regolatore deve dissipare una marea di potenza in forma di calore, e fa presto a friggersi ... quindi e' sempre meglio alimentarli con tensini comprese fra 7 e 9 V (anche usando semplicemente qualche diodo al silicio in serie al positivo, se si ha solo un'alimentatore da 12 o piu ... non sara' elegante, ma funziona piu che bene :P) ... come nell'esempio di prima dei 500mA, se fosse alimentato a 9V, dissiperebbe 2W, se fosse alimentato a 7V dissiperebbe 1W ... scaldando molto meno, e rischiando molto meno di bruciarsi ... ;)

Ho provato ad alimentare una nuova Arduino UNO. Dopo qualche secondo inizia infatti a scaldare molto il regolatore di tensione. (Ci ho appoggiato sopra un dito..) Ho staccato immediatamente! Credo che rinuncerò ad alimentarlo coi 12 volt... :| . Come carico non ho altro che due relè di questo tipo: http://www.banggood.com/Wholesale-5V-2-Channel-Relay-Module-Shield-For-Arduino-ARM-PIC-AVR-DSP-Electronic-10A-p-48610.html e un sensore a IR: http://www.banggood.com/Infrared-Obstacle-Avoidance-Sensor-For-Arduino-Smart-Car-Robot-p-72965.html

se non vedo male, i rele son muniti di transistor, quindi non dovrebbero essere "deleteri" per arduino e per il regolatore... almeno che...non colleghi ai +5V di arduino un carico esagaeratamente piccolo, tipo corto circito o poco via, che poi vanno sul relè... allora la cosa potrebbe avere un senso...

o... che addirittura il carico dei relè (della bobina) sia esagerato per arduino se son collegati ai suoi +5V (quanto assorbono, come e dove son collegati??)

Se non hai alternative, metti 5 diodi tipo 1N4007 o simili in serie al positivo dei 12V ... ogni diodo fa cadere circa 0.75V, quindi sul jack troverai circa 8V, e vedrai che il regolatore scaldera' molto meno ;)

Grazie mille!!! Potrebbe essere un ottima idea!!! Me la riservo in caso di insuccesso... Nel frattempo ho adattato un alimentatore di un vecchio cellulare Nokia. Ho testato la tensione in uscita e mi da 6 volt. Ho tagliato il jack e rivestito di stagno i due fili. Li ho collegati, il positivo a Vin e il negativo a gnd. Al momento sembra funzioni tutto!!! Domani proverò ad installare il quadretto che ho generato con la mia scheda Arduino e vi dirò se sono riuscito a fulminarla anche questa!!! :-D :-D :-D. Grazie mille a tutti e buona serata! ;-)

Se alimentavi a 12V con rele a 12V non avevi problemi