Problemi con X-Board Relay

Devo lavorare con la scheda di cui trovate anche la documentazione, a questo link:
https://www.dfrobot.com/wiki/index.php/X-Board_Relay(SKU:DFR0222)

Il problema, è che i pin sono inspiegabilmente instabili. Uno dei codici di esempio, conferma che il piccolo led è presente al solito 13, invece quando programmo la scheda al pin 13 non risponde nulla.

In più, i pin dei relè continuano a cambiare ogni volta che subiscono un digital write e l'unico modo per comunicarci è un ciclo for che esegue qualcosa su qualsiasi pin trovi per la sua strada.

Nella disperazione, ho pensato che magari per il corretto funzionamento voleva prima l'accesso e identificazione ad internet, tuttavia anche collegando i cavi e la scheda via usb al pc, fallisce la comunicazione in DHCP.

Sospetto che l'hardware sia difettato, ma il committente afferma che la scheda ha sempre funzionato correttamente con il vecchio programma che conteneva.

Qualcuno di voi ha idea di cosa io possa farci?

Buongiorno,
prima di tutto, essendo questo il tuo primo post nella sezione Italiana, nel rispetto del regolamento, ti chiedo di presentarti QUI (spiegando bene quali conoscenze hai di elettronica e di programmazione … possibilmente evitando di scrivere solo una riga di saluto) e di leggere con attenzione il su citato REGOLAMENTO

… poi, in conformità al suddetto REGOLAMENTO, punto 13, il cross-posting è proibito (anche tra lingue diverse) e tu stai parlando di quest’argomento già QUI dove, per altro, ti stanno già rispondendo e … non è bello abbandonare una discussione dove stanno cercando di aiutarti …

Continua quindi nel thread che hai già aperto, mentre questo, in violazione del regolamento, viene chiuso e in seguito cancellato.

Guglielmo