Problems connecting Yún to eduroam

Hi,
I´m quite new to both Arduino and OpenWRT environments. What I´m trying to do is to send some sensors' data to a Google Spreadsheet using the Temboo API.
For that, I´m trying to configre the Yún to access the eduroam network (WPA2 Enterprise).
I managed to connect once, but it suddenly stopped working (without changing anything). I am now getting deauthentication by local choice, reason = 3.
I don't know what to do, because I have tried several configurations and none work.
This one is my /etc/config/network file

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ipaddr '192.168.240.1'
        option netmask '255.255.255.0'
        option proto 'static'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option metric '10'

config interface 'wwan'
        option proto 'dhcp'

and this one the /etc/config/wireless one

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option txpower '16'
        option channel '1'
        option country 'SE'

config wifi-iface
        option network 'wwan'
        option ssid 'eduroam'
        option device 'radio0'
        option mode 'sta'
        option bssid '9C:5D:12:05:03:56'
        option encryption 'wpa2+aes'
        option eap_type 'peap'
        option ca_cert '/lib/uci/upload/cbid.wireless.cfg053579.ca_cert'
        option auth 'MSCHAPV2'
        option identity '*******'
        option password '*****'

Thanks in advance

baneado:
Hi,
I´m quite new to both Arduino and OpenWRT environments. What I´m trying to do is to send some sensors' data to a Google Spreadsheet using the Temboo API.
For that, I´m trying to configre the Yún to access the eduroam network (WPA2 Enterprise).
I managed to connect once, but it suddenly stopped working (without changing anything). I am now getting deauthentication by local choice, reason = 3.
:::SNIP:::

Please run this sketch: Yún WiFi Status.

Jesse

No matter, it's already solved. It was a problem with the certificate

Can you share what the problem was with the certificate? Probably having the same issue.

Thanks in advance!!

Cygne:
Can you share what the problem was with the certificate? Probably having the same issue.

Thanks in advance!!

And please change the pre-pend to the subject line [SOLVED].

TIA
Jesse

Hi ! Could you please share the solution ? We are working on a student project, and we need to connect to eduroam, we would be really happy if you could share !

Weavel44:
Hi ! Could you please share the solution ? We are working on a student project, and we need to connect to eduroam, we would be really happy if you could share !

@Weavel44,
the original post is over three (3) months old. They never responded with any requests, after they fixed their problem. Please start a new thread, so we can work on your problem.

TIA
Jesse