Problems flashing boot loader on atmega328 custom PCB

Hello I designed a custom PCB based off on the arruino nano schematic so there are no capacitors from the crystal and the 328, and when trying to flash the boot loader I get the following error.

avrdude: Device signature = 0xff00ff 
avrdude: Expected signature for ATmega328P is 1E 95 0F
Double check chip, or use -F to override this check.

I am using a USBasp to try and burn the boot loader. I know that I made a mistake with not making the reset pin accessible so I am using a jumper wire between the NC pin where the headers are and the reset on the button.

I have attached images of my schematic, please let me know if I am missing something.

This is the chip that I am using
https://lcsc.com/product-detail/ATMEL-AVR_ATMEL_ATMEGA328P-AU_ATMEGA328P-AU_C14877.html

Why did you omit the required capacitors for the crystal ?

The schematic for the arduino nano did not have them so I though it was okay.

Why do you say this ?

What do you mean?

Please post a link to the schematic

image
I see capacitors from the crystal to GND

Interesting, I though they were apart of the crystal. Is this the reason why I can’t burn the boot loader? I also tried to burn it just using the internal crystal and I still received the same error.

Without the caps the crystal will not oscillate

How did you do that and what are you using to burn the bootloader ?

Your reset button is also miswired!

I am using the MiniCore Plugin for arduino ide

@missdrew Where should it be wired too?

OK, but what hardware are you using to burn the bootloader ?

Your button needs rotated 90’. At the moment it is shorting the reset pin to GND. Also the 1K pullup is to strong, a 10K would be much better.

@missdrew Okay, removing the bottom allowed me to burn the bootloader using a USBasp, and I was able to load the blink program on there, but I still can not upload via USB with my FT232RL chip. I have the RX going to the TX and vise versa with a resistor going between them. Is there anything that I am missing?

I was able to figure it out. Thank you, guys. @missdrew @UKHeliBob

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.