Problems getting code verified and uploaded using Arduino Create online IDE

Hi everyone,

Hoping that someone could shed some light on my problem. I'm currently teaching a Grade 9 arduino course using Chromebooks and arduino-compatible UNOs. Things have been going very well for the past two months and students have really gotten into building circuits and writing code on Arduino Create's online IDE. However from Thursday last week, students have not been able to get their code verified using the Arduino Create online IDE. I had students try using code which worked previously but they continue to get the same error message despite the code being free of errors.

Here is the following error message that I get when trying to verify code:

./opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware opt/arduino-builder/hardware -hardware ./opt/cores -tools opt/arduino-builder/tools -tools ./opt/tools -built-in-libraries opt/libraries/latest -logger humantags -fqbn arduino:avr:uno -build-cache /tmp -build-path /tmp/733499762/build -verbose -prefs runtime.tools.avr-gcc.path=./opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs runtime.tools.avrdude.path=./opt/tools/avrdude/6.3.0-arduino14 -prefs runtime.tools.arduinoOTA.path=./opt/tools/arduinoOTA/1.2.1 -libraries /tmp/733499762/custom -libraries /tmp/733499762/pinned /tmp/733499762/sketch_sep17a

Linking everything together...

lto1: fatal error: bytecode stream generated with LTO version 3.0 instead of the expected 4.1

compilation terminated.

lto-wrapper: fatal error: ./opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-gcc returned 1 exit status

compilation terminated.

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld: error: lto-wrapper failed

collect2: error: ld returned 1 exit status

exit status 1

I'm unsure what to do and suspect that there is a problem with the Arduino Create online IDE. Any help would be greatly appreciated!

I don’t use Chromebooks nor the online IDE but this error usually means that you’ve one or more binary build results (.o files) which are incompatible with other .o which you’re trying to link them together and the linker barks at you.

This happens if you built your project with an older compiler version, then updated to a new compiler version (which they might have done behind your back on the web) and re-compiled part of your project as not all files have been modified.

something to explore could be to “make clean” - ie go back to a project where no .o exists and re-generate purely from source code the new build.

See other post regarding same problem. Likely an issue with the web version.

There are multiple other reports of this bug:

I recommend subscribing to those threads so that you’ll be sure to get news of any progress in fixing it.

This is an Arduino Web Editor specific problem so the workaround is to use the regular Arduino IDE, which you can download for free from:

pert: This is an Arduino Web Editor specific problem so the workaround is to use the regular Arduino IDE, which you can download for free from: http://www.arduino.cc/en/Main/Software

challenge I guess is that they are using Chromebooks not real computers. cheap... but not the most versatile product for a school or offering a great experience to students.. does the job for computerized testing but with the rest YMMV..

reminds me of VT100 days... :)

Ah yes, I just did a copy/paste reply. But supposedly it's fairly easy to run the Arduino IDE on ChromeOS: https://forum.arduino.cc/index.php?topic=554826.0 Perhaps not something that a school would want to mess with, I don't know. It would save them the monthly fee for using the Arduino Create Chrome app but I seem to remember hearing that the educational plan is actually quite reasonably priced.

Hello @ChristopherWong, we are sorry for the issue but the problem is not related in any way with the Chromebook itself.

We are working on a fix, please follow topic Issue 2018-10-30: lto-wrapper error prevent compilations for further information and updates about this.

Thank you.