Problems, Problems, Problems

I just bought an Arduino, and I am now using the Arduino software. It seems easy to use, but I am having way too many problems with it. About 80% of the time when I try to open the program, it does not open at all. Also, when I want to open a sketch that I saved, (and yes, I fixed the file associations) it rarely opens. When Arduino DOES open, I have to go into FILE ---> SKETCH ---> OPEN and choose the file manually from the browser. Should I go back to an older version? I am curious why the programmers posted the Alpha version as the primary download like on software-- I just can't seem to be able to use it! Help!

Which operating system are you using?

How are you trying to run Arduino? What happens (when it fails to open successfully)?

As strange as it sounds, opening a sketch directly from your desktop isn't usually a common operation, as sketches that are saved in the default location automatically appear in the Sketchbook menu in the IDE. It's something that we should fix though.

The "Alpha" moniker has applied to every version of the software so far; 0010 shouldn't be any more unstable than older versions (in fact, it should be more stable).

I am using Windows XP Home Edition. Should I be using a version built into an installer (if that exists?). I did notice that the whole Arduino program doesn't have to be "installed" per say (it's just all in one directory with the executable that accesses the other files needed for it to run in the directory). When it fails to open (when I click it; whether I click the shortcut I mad on my desktop, or the actual executable in the Arduino software directory it does not make a difference), all that happens is my HDD drive flashes for like 5 to 8 seconds, and then stops, not having loaded Arduino. Oddly enough, I am now discovering this stands true for Processing as well. As for the opening files outside of Arduino, how is that not common? What if I want to move, manipulate, and organize my various source code files into categorized folders? I have a lot of different programs written in BASIC and C on my PC, and I like to move them around and manipulate them from Explorer (aka "My Computer") so I can find them easier in the future. I hope that doesn't sound picky or anything... :-/. Is the Arduino software as well as Processing in early development?? Thanks!

Man, I just CAN'T get it to work at ALL now! I tried restarting my PC, updating Java, re-downloading the software...I don't know what to do! :'(

Have you tried the run.bat? That's sometimes more reliable than the executable.

That doesn't work, either. The command prompt comes up with an error that says: "Error occurred during initialization of VM java/lang/NoClassDefFoundError: java/lang/Object. Maybe that'll help...?

Hmm, sounds like the Java install is messed up. What is JAVA_HOME set to in the run.bat file? What happens if you open a command prompt, cd to the Arduino directory, and run "run.bat" from there? Does java\lib\rt.jar exist?

Ok. I cd'd to the directory, and tried to run run.bat. Didn't work; came up with the same error. I also tried to run the arduino exec. from there. Same thing. I checked for the rt.jar file. It was there. Just out of curiosity, I tried to run it. Should it have run properly? Because I tried to run it and it said: "Failed to load Main-Class manifest attribute from [......\ directory ---> rt.jar]. Hmmm...

And what's JAVA_HOME set to in the run.bat file? You might try putting a semi-colon ";" at the end of the set CLASSPATH= line (after mrj.jar). Or putting the value assigned to CLASSPATH in "double quotes". Also, try changing the line:



%JAVA_HOME%\java -verbose

It won't fix anything, but might help us figure out what's wrong. Try running it again and posting the output here.

Erm...I don't quite understand what you're getting at. Could you elaborate a little. Thanks!

Sure. Open up the run.bat file in a text editor (like notepad or wordpad). Then it should make more sense.

Ok. It says " set JAVA_HOME="java\bin" " (JAVA_HOME set to). I have to admit, when I talked about programming in C, I meant to say variations of C. So, I edited the run.bat file in a text editor...but how can I re-compile it as a .batch file? With something like Bloodshed Dev C++?? I mean, you can't run a text file as a program...Thanks!

Actually, you can run this type of text file as a program. Just open it in a text editor, make the changes, and run it again. No compilation necessary.

Nope. Same error as before. :'(

What’d you try?

Did adding -verbose to the command line provide any more information?

I did everything you told me to; even combinations of that. And yes, I added the -verbose to that section. It didn't do anything...

Ok. I figured something out. This may help you solve some bugs. If I bring up properties on the run.bat file, and set it in compatibility mode for Windows 95, then it runs correctly! But if I try to set the actual main Arduino executable for compatibility mode for Win 95, it does not start up just as before. Unfortunetely, I can’t seem to find a workaround for Processing… :-/

Weird. I'm glad you got it working. And thanks for letting us know how - it should come in useful.

Just to clarify, I have to run Arduino by clicking run.bat when it is set to that mode. I don't just set the run.bat file to Win95 compatibility and run the Arduino exec. That doesn't work. Just thought you might want to know that for future development.