Problems reading from MAX31865 Breakout board

Hi all,
I am trying to measure the temperature with an PT100, an MAX31865 board and an Arduino UNO. The PT has two wires and I soldered on each field (F- and field F+) a wire with one port and the port next to it.
The Ports are connected as followed:

MaxBoard/UNO
Vin/5V (also tried it with 3.3V on this port and 3.3V on Port 3V3)
GND/GND
CLK/pin13
SDO/pin12 (=MISO on Master)
SDI/pin11 (=MOSI on Master)
Cs/pin 10 (=selection of device pin)
For now, I use a basic code with one PT100 (two are the goal).

#include "SPI.h"
#include <Adafruit_MAX31865.h> // Adafruit's Header file 

// use hardware SPI, Write your CS pin
Adafruit_MAX31865 max_1 = Adafruit_MAX31865(10);
#define RREF      430.0 // 0.43Kohm the resistor is marked with 4300
 
#define RNOMINAL  100.0 // PT100

float operatMax31865_1(void) {
  float temperature_1 = max_1.temperature(RNOMINAL, RREF);
  return temperature_1;
}

void setup() {
 max_1.begin(MAX31865_2WIRE);
 Serial.begin(115200);
}

void loop() {
  Serial.print("PT100_1: "); Serial.print(operatMax31865_1()); Serial.println("°C ");
  }

Here the problem: The serial monitor shows one or two times a fitting temperature and after that only nonsense like :
⸮⸮A⸮s⸮T⸮⸮⸮⸮A⸮T⸮!⸮A⸮⸮⸮⸮⸮⸮@⸮⸮⸮T⸮⸮T⸮B⸮⸮⸮B⸮@⸮T⸮⸮R⸮@⸮P⸮@⸮w⸮⸮⸮

You can also see in the attached picture.

The writing of the nonsense is never ending and not even the reset button can stop it. I have to cut the power.
I already tried the example code “max31865” and the result is nearly the same.
I made a complete new setup where I changed each part and got the same result.

Thanks for any help!
Sepp

Hi,
You have the baud rate on the IDE monitor set to 9600, it needs to be set to 115200, that same as in the code.

Tom... :slight_smile:

Never mind,
I solved the problem. My mistake was that the delay in the void loop was missing and the serial monitor had a problem with it. I should have known better :sweat_smile:
Thanks anyway.

And I haven’t seen your answer. Thanks Tom you were completely right! :slight_smile: