Problems uploading a sketch to the MKRFOX1200

Hi,

I have just received 2 x MKRFOX1200 but unfortunately faces problems with uploading new sketched to one of the two devices :frowning: .

When I plug in the malfunctioning device it is correctly discovered as a COM port. But when I press upload on a BareMinimum sketch, it will print out:


PORTS {} / {} => {}
PORTS {} / {} => {}
PORTS {} / {} => {}
PORTS {} / {COM3, } => {COM3, }
Found upload port: COM3
C:…\Local\Arduino15\packages\arduino\tools\bossac\1.7.0/…

and then just keep hanging.

This is what I have tried so far:

  • Uploading a sketch from several different laptops (works for the “working” MKRFOX1200).
  • Tried several different USB cables (works for the “working” MKRFOX1200)…
  • Double-tapping the reset button.

I have read the following similar topics:

but none of their suggestions seem to work.

Any ideas?

/ Andreas

Did you try the "quickly double tap the reset button" trick ? It will put it on a new com port (bootloader mode) but is usually the way around any issues.

Also ensure you are using USB 2.0 ports and a usb cable capable of data transfer (not all usb micro cables support data). There have been issues with USB 3.0 ports and cables in the past.