Problems uploading sketch from Macbook Pro

I have a Mac Pro and a Macbook Pro. Both are running OSX 10.6.8 and both have the Arduino IDE ver 0022 installed. From my MacPro I can upload programs to my Arduino Duemilanove (Atmega 328). But when I try to do it from my Macbook Pro (using same USB cable and same program), I get this error:

Binary sketch size: 11524 bytes (of a 32256 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x86 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x1e

I know the mackbook pro is on the right port and communicating with the arduino because when I open the serial monitor, I can see the text my sketch is sending to it using serial.print command.

Any idea why I'm having problems with my MacBook Pro and ardunio?

-Scott

One more thing to add, my MacPro is 32-bit OS, the MacBook Pro is 64-bit.

Try the other USB port.

I have the same problem with both USB ports

Hey everyone,

I got a problem similar to ScottG:
I roamed the forum and the rest of the www in English and in German (and in French) for any solution and close to a solution to my issue for two weeks, now and I got little that could help me out of this situation. Well, let’s get started:

• Your operating system.
= MacBook Pro, 15inch, using OS X Lion (10.7.2), 32-bit, 8GB RAM and still 297 GB free space, which was bought this summer; used Time Machine to get the system from my old MacBook (13inch, OS X 10.5, Snow Leopard)
• What kind of board you have. […]
= I tried both: Uno and Decimiela; either were connected directly with a USB cable.
• Whether or not you were ever able to upload to the board. If so, what were you doing with the board before / when it stopped working, and what software have you recently added or removed from your computer?
= The error message says, the USB port is already in use. (More information: go to the last point.)
Uploading a sketch has not worked, yet.

First, the obvious:

  • Yes, I checked, if I chose the right Serial Port in the Arduino Menu and
  • I checked, if the right board was chosen.
    …then the hardware:
  • the boards were brand new and working (again: on other computers)
  • I changed the USB cable (3 different ones, but all of them were working fine on the other Macs and Windows Laptops and Computers)
  • the boards do respond, since their integrated LEDs were on
  • the USB device is recognized by the computer

…next, anything else:

  • the sketch is fine, since THE WHOLE CONSTRUCTION WORKED on other Macs and PCs (Operating systems: 10.5, or: OS X Leopard and OS X Snow Leopard; Windows XP and Windows 7)
  • no other application is running (not even the “little snitch”)
  • firewalls & bluetooth are off
  • I tried uploading the sketch while internet connection was on and while it was off
  • I tried running the sketch (and others as well) on a guest account on my MacBook Pro
  • I checked all updates for my Mac, for Arduino and the FTDI drivers, it is using, means: I now have installed Arduino 23 and the driver it’s been coming with. But I also tried out the version 22 (which I had on my Laptop at first and then deinstalled it) – without luck.

And what else might be something to think about:

  • Processing is installed, but was not running during my try-outs
  • There is a Bootcamp partition with Windows 7 on my MacBook Pro (with 35 GB space – almost half of it in use – which is running perfectly fine)
  • this MacBook Pro has also problems with the application “(apple) Mail” (it can’t view the work space/any received messages), which derived from my old MacBook and couldn’t be fised in the store; HOWEVER:
  • I was able to run the sketch on my old MacBook (13inch, using OS X Snow Leopard), which is a refurbished MacBook from 2008 (I bought it in the same year). And my old baby has got an older version of Processing as well…

• The messages displayed when you try to upload with verbose output enabled. […]

ERROR MESSAGE:
start_______________________

Serial port ‘/dev/tty.usbmodemfd121’ already in use. Try quiting any programs that may be using it.

Binary sketch size: 3236 bytes (of a 32256 byte maximum)
processing.app.SerialException: Serial port ‘/dev/tty.usbmodemfd121’ already in use. Try quiting any programs that may be using it.
at processing.app.Serial.(Serial.java:144)
at processing.app.Serial.(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:75)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:1568)
at processing.app.Sketch.exportApplet(Sketch.java:1524)
at processing.app.Editor$DefaultExportAppHandler.run(Editor.java:2327)
at java.lang.Thread.run(Thread.java:680)
processing.app.debug.RunnerException: Serial port ‘/dev/tty.usbmodemfd121’ already in use. Try quiting any programs that may be using it.
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:99)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:1568)
at processing.app.Sketch.exportApplet(Sketch.java:1524)
at processing.app.Editor$DefaultExportAppHandler.run(Editor.java:2327)
at java.lang.Thread.run(Thread.java:680)

end______________________

I hope you can save me from deinstalling my beloved, old system and “reinstall” every programm and personal file back on.
I let others help me and overlook the procedures I’ve been trying out, to have any operation done at least twice – 2nd time with s.o. else, together.
Any help is more than apprecated.

Marizon

marizon: I got a problem similar to ScottG:

Similar, but completely different. The original poster is getting the generic sync error. You are getting a very specific error.

marizon: ERROR MESSAGE: ________________________start_______________________________________________

Serial port '/dev/tty.usbmodemfd121' already in use. Try quiting any programs that may be using it.

Something is holding the serial port open. Does this always happen or just after one upload works?

Drop to a terminal and run:

# lsof | grep usbmodem

This will list any applications/processes that currently have the modem/serial port open. (Many times cellular data devices are the culprit. They just like to latch on to anything that looks like a serial device.)

This probably doesn't help, but I'll elaborate on my original post. Like Marizon I'm running bootcamp with Win7 on my macbook book pro. I was able to upload sketches to the Uno, it was only the Duemilanove that had problems (both had the standard Ethernet shield). Nw for some mysterious reason, the Macbook pro started working with the Duemilanove board. I didn't do anything, just tried it again the next day.

Hi James(C4S),

thanks for your fast reply!

Something is holding the serial port open. Does this always happen or just after one upload works?

It has never worked, yet on the MacBook Pro. So: yes, it always happens.

Drop to a terminal and run:
Code:

lsof | grep usbmodem

I tried this in Terminal, but nothing appeared after this code.

Would it be helpful if I post the program’s (meaning Arduino as a program itself) preferences text?
Note: I just noticed that my Library was missing when trying to track it manually. It was greyed out when viewing it through the path shown in my screenshot. I had to make an alias to enter it and upload the preferences text.

Anyways, for other followers: attached is that source code and a screenshot of were to find it.

I’m excited to hear more suggestions.

Best,
Marizon

Screen Shot 2011-12-06 at 8.49.13 AM.png

preferences.txt (2.66 KB)

OK, problem was solved: I had to move java somewhere else. Where to and why exactly I don't know, but I got the answer here:

http-//www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1211165807/6

And this code was used:

Code: $ sudo mkdir /var/lock $ sudo chmod 777 /var/lock

Credits to Phil.