Problems uploading sketch to board

Hi...sorry for my English :sweat_smile:.

I have a problem. Help me, please :wink:
I have a 3d printer with a Melzi 2.0 5v board. I've set up it for a Sanguino board ATmega1284P and it compiled well. I use Arduino 1.8.10 and Marlin 1.0.x.

The problem comes when I try to upload the Marlin sketch to board. I receive this error message.

Arduino: 1.8.10 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 45116 bytes (34%) of program storage space. Maximum is 130048 bytes.
Global variables use 2692 bytes (16%) of dynamic memory, leaving 13692 bytes for local variables. Maximum is 16384 bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x61
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x72
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x0a
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x63
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x68
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x6f
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

What does that mean? Which is the problem? How can I fix it?

Thank you for your time.