Problems uploading the bootloader on a ATmega644P-20PU

Hi all :)

For a week trying to load a bootloader on the chip that I put in the subject post and goes nothing....

Not exaggerating when I say I've tried like 30 tutorials.....

Lauszus, sanguino, sanguino-master, atmega644....I have tried them all and nothing...

Mi connections are this:

UNO REV3----->644P-20PU

10------------->9 RESET 11------------->8 SCK 12------------->7 MISO 13------------->6 MOSI VCC----------->VCC GND---------->GND

I upload bootloaders onto a Atmega328/1284 without problems....I don´t know what happening.....

Someone has the "good bootloader" hiding out there ???

Thanks for any comment :) (I used the ide soft from 1.0.1 to new beta...)

Try Nick Gammon's bootloader sketch. http://www.gammon.com.au/forum/?id=11635

You have the 644 set up 10k reset pullup resistor, 0.1uF caps on VCC, AVCC, 16 MHz xtal and 22pF caps?

Hi, yes....I tested with and without components (On two how-tos, the users uploaded the bootloader only with vcc and gnd)

Thanks for the link...Lets go to see :)

Regards :)

In folder, I don´t see the file for 644...

Atmega 8 Atmega 168 Atmega 328 Atmega 1280 Atmega 1284 Atmega 2560 Lilypad

Any idea??

Use the 1284 bootloader. Same chip basically, more memory.

When you create a boards.txt set of entries in the IDE, you'll have to adjust the memory size accordingly.

Sorry, but don´t work with 1284....

All time give me "invalid signature"....

Regards :)

I think you have your pins mixed up on the Uno.

Uno D13(SCK) D12(MISO) D11(MOSI)

I think you have your pins mixed up on the Uno.

Uno D13(SCK) D12(MISO) D11(MOSI)

Exactly...and D10(!SS).

Hi :)

Yes, you´re right..In the description of the pins I was wrong...

10-9 11-6 12-7 13-8

I have solved 5 minutes ago....One friend send me his sanguino and it worked perfectly...One minute and 644 fully operational :)

Thanks all for your support :)

Regards :)