Problems using mysmartUSB mk2

Hello to everybody!

I am trying since days now to programm my arduino using an external programmer named mysmartUSB mk2. I added following lines in the programmers.txt file.

avr911.name=mySmartUSB MK2
avr911.communication=serial
avr911.protocol=avr911

and in the preferences I changed the line "upload.using=bootloader" to "upload.using=avr911". I always get the error message:

avrdude: stk500_getsync(): not in sync: resp=0x00

I have tried with arduino ide 1.0 and 1.5 but if I try to upload with the same programmer using atmel studio 6 and an atmega8 it works. The only thing that seems strange to me is that in the prog_tool enviroment it says i am using a 910 and not a 911 maybe this is the problem? anyone an idea? I am thankful for every little help anyone can give me.

Thanks in advance and greetings

Stefan

Hi Stefan,

I had the same problem with the programmer like you.
I also started with adding the programmer to “programmers.txt” but I couldn’t convince the IDE to use the selected programmer.

So I decided to go the “hard coded way” ==> forget about the nice configuration menus in the GUI and tell avrdude direct what it should do :wink:

Here is my way to succeed:

  • install version 1.5.8 (avrdude version 6.0.1 is bundled with this version, which I need for my ATmega328P)

  • open “~/arduino-1.5.8/hardware/arduino/avr/platform.txt” with editor

  • in line 85 change the following values:

  • -c{upload.protocol} >>> -cavr911 (avr911 is the protocol supported by the mysmartUSB mk2)

  • -b{upload.speed} >>> -b19200 (max. speed for the mysmartUSB mk2)

  • -D >>> DELETE the -D option!

Here is the code section with the new “tools.avrdude.upload.pattern” config:

# AVR Uploader/Programmers tools
# ------------------------------

tools.avrdude.cmd.path={runtime.ide.path}/hardware/tools/avr/bin/avrdude
tools.avrdude.config.path={runtime.ide.path}/hardware/tools/avr/etc/avrdude.conf

tools.avrdude.upload.params.verbose=-v -v -v -v
tools.avrdude.upload.params.quiet=-q -q
tools.avrdude.upload.pattern="{cmd.path}" "-C{config.path}" {upload.verbose} -p{build.mcu} -cavr911 -P{serial.port} -b19200 "-Uflash:w:{build.path}/{build.project_name}.hex:i"


tools.avrdude.program.params.verbose=-v -v -v -v
tools.avrdude.program.params.quiet=-q -q

With this changes I could upload my sketch.

good luck!
Gerhard