Problems with Ethernet Shield W5100

Hello, my problems with the etherent shield w5100 is that i cannot ping the device.
I tried webserver arduino exemple and my router is seeing my device online with static ip 192.168.100.120 and led status up(LAN 3), my router ip is 192.168.100.1.Sometimes when i tried ping from pc to arduino the TX pin is blinking and RX never saw blinking.
My router is Huawei HG8247H, arduino uno+ shied ethernet w5100 i power the arduino from usb port.

web_server.ino (2.99 KB)

Try this sketch. Does it display the network settings you would expect from your router’s dhcp server?

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = {  0x00, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };

void setup() {
  Serial.begin(9600);

  // disable SD SPI
  pinMode(4,OUTPUT);
  digitalWrite(4,HIGH);

  Serial.print(F("Starting ethernet..."));
  if(!Ethernet.begin(mac)) Serial.println(F("failed"));
  else {
      Serial.println(Ethernet.localIP());
      Serial.println(Ethernet.gatewayIP());
  }
}

void loop() {
}

I tried the sketch and show me Starting ethernet… failed

There could be a couple reasons it is failing.

It could be a cheaper ethernet shield. Some have incorrect value resistors between the W5100 and the RJ45 socket.

It may not be a w5100. Are you certain it isn't a w5200, w5500, or enc28j60 ethernet IC?

It could be a bad cable.

The Ethernet Shield is WIZnet Ethernet W5100 and i made search on the internet and my smd resistor next to ehternet port is 511 and i think that it is the problem. I have a multimeter but the smd resistor have 8 pins and i don't know how to measure.

If it is marked 511, that is probably your problem. I think it should be 510. 500 ohms is too much resistance.