Problems with gcc-arm-none-eabi-4.4.1-2010q1-188-win32.tar.gz file on build IDE

Ok one of the needed tarball probably was not created using the --hard-dereference flag, so when building the IDE 1.5 this errors show up:

windows-unzip-arm-toolchain: [exec] tar: g++_arm_none_eabi/arm-none-eabi/bin/g++.exe: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/bin/c++.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/arm-none-eabi/lib/armv6-m/libg.a: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/lib/armv6-m/libc.a': Operation not permitted [exec] tar: g++_arm_none_eabi/arm-none-eabi/lib/libg.a: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/lib/libc.a': Operation not permitted [exec] tar: g++_arm_none_eabi/arm-none-eabi/lib/thumb/libg.a: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/lib/thumb/libc.a': Operation not permitted [exec] tar: g++_arm_none_eabi/arm-none-eabi/lib/thumb2/libg.a: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/lib/thumb2/libc.a': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-ar.exe: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/bin/ar.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-as.exe: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/bin/as.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-g++.exe: Cannot hard link tog++_arm_none_eabi/bin/arm-none-eabi-c++.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-gcc.exe: Cannot hard link to g++_arm_none_eabi/bin/arm-none-eabi-gcc-4.4.1.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-ld.exe: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/bin/ld.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-nm.exe: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/bin/nm.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-objcopy.exe: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/bin/objcopy.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-objdump.exe: Cannot hard link to g++_arm_none_eabi/arm-none-eabi/bin/objdump.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-ranlib.exe: Cannot hard link tog++_arm_none_eabi/arm-none-eabi/bin/ranlib.exe': Operation not permitted [exec] tar: g++_arm_none_eabi/bin/arm-none-eabi-strip.exe: Cannot hard link to `g++_arm_none_eabi/arm-none-eabi/bin/strip.exe': Operation not permitted [exec] tar: Exiting with failure status due to previous errors [exec] Result: 2

To make the builded IDE working I had to install this files manualy copying them from the oficial online IDE zip.

I think this tarball should be fixed so that can be extracted anyware.

Hi Baltasar,

may you provide more details on your OS? i've tried the full build on Windows 7 and it worked without issues.


I have windows XP Pro and used the latested Cygwin version with all the most recent tools needed to build it.

Anyway going to try today on a real Linux SO just to see how it goes.