Problems with new ESP-8266 module used on Arduino UNO

Greetings everyone,

I’m new to this, so I am here to ask for help. I just got my ESP-8266-01 module and I’m trying to use it on Arduino UNO. It was ~1$ and it’s the black one (I heard black ones are newer). So… I have watched many tutorials and read many documentations, but I am still not being successful what I desire.

I understood that ESP’s require a firmware to be flashed into them, but I heard that mine has one already built in.

What I want:
I want my ESP-8266-01 to connect to arduino and act as an Access Point for mobile devices. I heard that I must programm my ESP (upload the code to it), but since I don’t have a programmer, I am trying to do it with my Arduino.

The code I wish to upload to it is:

/* Create a WiFi access point and provide a web server on it.
ESP8266 Arduino example
 */

#include <ESP8266WiFi.h>
#include <WiFiClient.h> 
#include <ESP8266WebServer.h>

/* Set these to your desired credentials. */
const char *ssid = "ESPap";
const char *password = "thereisnospoon";

ESP8266WebServer server(80); 

/* Just a little test message.  Go to http://192.168.4.1 in a web browser
 * connected to this access point to see it.
 */
void handleRoot() {
  server.send(200, "text/html", "<h1>You are connected</h1>");
}

void setup() {
  delay(1000);
  Serial.begin(115200);
  Serial.println();
  Serial.print("Configuring access point...");
  /* You can remove the password parameter if you want the AP to be open. */
  WiFi.softAP(ssid, password);

  IPAddress myIP = WiFi.softAPIP();
  Serial.print("AP IP address: ");
  Serial.println(myIP);
  server.on("/", handleRoot);
  server.begin();
  Serial.println("HTTP server started");
}

void loop() {
  server.handleClient();
}

(Found it on the internet)

Everytime I tried to do it, my IDE said:

the selected serial port _
 does not exist or your board is not connected

, either

File "C:/Users/jovan/Documents/ArduinoData/packages/esp8266/hardware/esp8266/2.5.1/tools/esptool\esptool.py", line 468, in connect
    raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

I just can’t seem to get it to work. I tried grounding and ungrounding the IO0 pin on ESP, as well as pressing the reset buttons and holding it, but nothing seemed to work.

I set my board to ESP-8266 in IDE, and my PORT to Arduino UNO (COM5). Is anyone willing to help me investigate what’s the problem, since I already spend so much hours giving tutorials a try without actually succeeding. If anyone is willing to help, I would please for him to pass me a screenshot of a circuit I should connect, a list of steps I should do/try, etc. I am really new to this.

Thanks in advance!

"It was ~1$ and it's the black one"

It might be worth your time to get a ESP8266 development board like the WeMOS D1 that works from the start. You will only be out the ~$1 and your time so far.

I am sorry, but that is not a type of help I was asking. I would like to receive help related to the problem I explained, but thanks anyway!

wellnesscookie:
I am sorry, but that is not a type of help I was asking. I would like to receive help related to the problem I explained, but thanks anyway!

Too bad you are too pigheaded to listen to excellent advice.

I concur with zoomkat.
I have worked with the ESP-01, and I have gotten it to work, but was a major pain in the butt.

But since you insist on doing it the hard way, read :https://www.hackster.io/jeffpar0721/add-wifi-to-arduino-uno-663b9e
I got it working even though the original article had major errors.
It makes the ESP-01 an access point.
Nothing about creating a web server.
You are on your own.

The reason I wrote that is because I am not in the position to get a new one and if I was, it would take up to more than 50 days for it to come to my address. I need to finish the project I am working on in 10 days. Sorry and thanks in the same time.