Problems With SFE FTDI Breakout Board

I'm using the 5V FTDI breakout board from SparkFun ( with a 5V/16MHz Arduino Pro Mini. I've programmed it successfully before, but the FTDI board keeps becoming unrecognized by Windows XP SP3. When I plug in the board, I get a balloon from the system tray saying "USB Device Not Recognized." I have it connected through a USB hub and I've used it successfully when connected that way before. I've tried connecting it directly to USB on the motherboard and I get the same result. I've uninstalled drivers, reinstalled drivers, but nothing seems to work. Is there anything else I can do? Thanks

I had a similar problem with my Arduino board getting not recognized by windows XP.

At first it worked and I could program it. Then after a while windows would give that error message “USB Device Not Recognized” or maybe “One of your USB devices has malfunctioned.” Then it would work again, and stop again.

In my case, the problem was caused by a poor quality USB cable. When I tried a good quality high-speed USB 2.0 cable from a different manufacturer then the board worked consistently. I could make the problem appear and disappear by alternating the good and bad cable.