Processing 3.0 / ADKMode / Android SDK - Mac OSX


I’m new to the Mega ADK / Android (but have been doing Arduino Uno stuff of years)… have been going through the getting started guide for the Mega ADK. Downloaded Processing, Downloaded the ADKMode and moved it to the ADK folder, Installed Android Developer Kit, etc. I’m on a Mac with newest OS. Sierra

It appears that the ADKMode download isn’t compatible with Processing 3.0. I tried with Processing 2.2 and it works fine.

However, with Processing 2, it doesn’t seem to recognize the latest version of the Java ADK… (looks like that was just updated Dec 6). I get this message (“The Android SDK doesn’t not seem to be installed”…see attached), which I can’t figure out how to solve.

So I’m stuck. Any help/advice on how to get started?

Thanks so much!



Just an update. I eventually figured this out... Processing 3.0 incorporated the ADK into the Android mode (, so there is no need for ADK mode (the Arduino tutorial is out-of date!)

It's still a pain. I had to install/re-install many times and finally it worked. Am now connected and can run an app through processing and communicate with my Mega.

Any other Mega ADK users out there? It seems that these questions are far and few between...and the amount of info/advice is pretty limited.


Thanks for this note (Ive failed to install AdkMode). As for now the Arduino tutorial is still out-of date.