processing issues (wrong section???)

sorry if this is the wrong section, there isn’t a section just for processing I don’t believe.

but here is my issue/
I downloaded and tried the processing test app from the wiki. each pin input or output or servo move… worked good… I even did some charlieplexing with it.

but I am having issues with the sample code from the playground here
http://www.arduino.cc/playground/interfacing/processing

here is the code:
import processing.serial.;
import cc.arduino.
;

Arduino arduino;
int ledPin = 13;

void setup()
{
//println(Arduino.list());
arduino = new Arduino(this, Arduino.list()[0], 57600);
arduino.pinMode(ledPin, Arduino.OUTPUT);
}

void draw()
{
arduino.digitalWrite(ledPin, Arduino.HIGH);
delay(1000);
arduino.digitalWrite(ledPin, Arduino.LOW);
delay(1000);
}
//end code
and here is the error message
Stable Library

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Exception in thread “Animation Thread” java.lang.IllegalAccessError: tried to access class processing.core.PApplet$RegisteredMethods from class cc.arduino.Arduino$SerialProxy
at cc.arduino.Arduino$SerialProxy.(Arduino.java:119)
at cc.arduino.Arduino.(Arduino.java:168)
at sketch_121124a.setup(sketch_121124a.java:33)
at processing.core.PApplet.handleDraw(PApplet.java:2103)
at processing.core.PGraphicsJava2D.requestDraw(PGraphicsJava2D.java:190)
at processing.core.PApplet.run(PApplet.java:2006)
at java.lang.Thread.run(Thread.java:662)

after seeing this, I assumed there was some sort of java error so I updated java on my computer too… but that did not help at all

any advice or help would be great

thanks in advance

there isn't a section just for processing I don't believe.

Well there is, the title heading says:-

Interfacing w/ Software on the Computer Firmata, Processing, Max/MSP, PureData, VVVV, etc.

So I am not sure how much clearer you want it.

I assumed there was some sort of java error

It looks like it. Narrow it down. Can you load any of the processing examples? Can you load the serial communication examples.

You commented this out

println(Arduino.list());

are you sure your port appears as the first one on the list?

Also use the code tags when posting code. That is the # in the reply box.