prog'g MKR1000 using Atmel Studio 7

I want to use Atmel Studio 7 to program my MKR1000 and run the WINC1500 example projects. Can the USB port be used for prog'g or is the JTAGICE debugger required? Has anyone written a Board Specific file for this MKR1000?
Your suggestions are welcome.
Thanks

here's an update on my research for this topic;
*MRK1000 does not have EDBG support for the Atmel debugger hence USB programming does not work.
*MRK1000 has a 10-pin mini-connector that is Not wired for JTAG. JTAGICE programmer does not read the board.
*Atmel Studio 7 does not have the Board Specific package required to communicate with this board. Only the Arduino Zero has this support built into Atmel Studio.
*The JTAGICE has an octopus cable (free connector receptacles) that can attach to the I/O pins on the MKR1000. This might give the required programming connection but without the Board Specific package, this connection does not work.

So, your thoughts and suggestions are still welcome!

Have you asked about this on GIT ?

You may be more likely to get something there.

GITHUB MKR1000

All I have to contribute as its way above me.

Thanks for your suggestion.
I started watching the Git you mentioned.
It's for the Arduino dev environment but does not include Atmel Studio 7.
Hopefully, someone will figure this out.
Best regards

You could actually ask over there...its where all the real genius are.

I know it's quite old post, but I found way to program MKR1000 with AS7. My solution uses same way that Arduino does. You can take every advantage AS gives you, including ASF. Here's instructable covering this subject.

Hi to all.

I’m new to this forum, so please excuse any mistake.

I’m currently working on a project, where I would like to use the MKR1000 with Atmel Studio 7 (AS7).
I followed the instructions how to program the MKR1000 via AS7 from the following links:

http://instructables.com/id/Programming-Arduino-Due-With-Atmel-Studio-ASF
Atmel Studio 7 - Programming the Arduino Uno via the bootloader without programmer. - YouTube

The result shows:

…Debug>"…AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0/bossac.exe" --port=COM8 -i -e -w -v -b “…\Debug\Blink_samh.bin” -R
Atmel SMART device 0x10010005 found
Device : ATSAMD21G18A
Chip ID : 10010005
Version : v2.0 [Arduino:XYZ] Nov 24 2015 11:35:16
Address : 8192
Pages : 3968
Page Size : 64 bytes
Total Size : 248KB
Planes : 1
Lock Regions : 16
Locked : none
Security : false
Boot Flash : true
BOD : true
BOR : true
Arduino : FAST_CHIP_ERASE
Arduino : FAST_MULTI_PAGE_WRITE
Arduino : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
done in 1.065 seconds
Write 2092 bytes to flash (33 pages)
[==============================] 100% (33/33 pages)
done in 0.017 seconds
Verify 2092 bytes of flash with checksum.
Verify successful
done in 0.002 seconds
Set boot flash true
Ignoring set boot from flash flag.
CPU reset.

Seems to me good, so far!

Now the issue, the uploaded code isn’t running.
My simple code is:

#include "sam.h"


int main(void)
{
    /* Initialize the SAM system */
    SystemInit();

    /* Replace with your application code */
	REG_PORT_DIRSET0 = PORT_PA20;
	REG_PORT_DIRSET0 = PORT_PA23;
	int i;
	
    while (1) 
    {
		for (i=0 ; i<150000 ; i++) ;
		REG_PORT_OUTSET0 =  PORT_PA20;
		REG_PORT_OUTSET0 =  PORT_PA23;
		for (i=0 ; i<150000 ; i++) ;
		REG_PORT_OUTCLR0 =  PORT_PA20;
		REG_PORT_OUTCLR0 =  PORT_PA23;
    }
}

I tested the whole thing against the SAMW25 Xplained and there it worked without any issue.
Any ideas what is wrong with my attempt on the MKR1000?

Thanks in advance for any help.