Program lilypad without FTDI Board?


I bought a lilypad and it did not come with an FTDI board (it appeared on the website that it did).

I was kind of hoping to use it over the weekend, so it's impossible for me to order one at the moment.

Can I use my duemilanove to ICSP the lilypad?

It appears like I can, but I'm not too sure on the specifics, especially can arduino sketches still be uploaded via the ICSP?

What wiring and software is needed?

I've read a few of the tutorials but I think I might be in over my head, unless someone can lay it out in easy to understand steps.

Also, please be kind, I'm very new to arduino and electronics in general.



Hi Ashley,

This should do what you want:

Use the first example, "Circuit (targeting Arduino Duemilanove or Diecimila)", with your Lilypad on top.

Alternatively, if you just want to upload sketches to the Lilypad and don't want to go through all the ICSP stuff you could just remove the ATMega328 chip from your Duemilanove then jumper across wires connecting +5v, ground, reset, TX and RX and program it directly.

Good luck!

That's great, thank you, I had already read that link but wasn't sure it is what I wanted.

I understand the connections they have made, but I read that it is used to burn the bootloader, not to program the arduino with sketches.

How do I use this method to copy sketches to my lilypad?

Cheers :~


Sorry, I hit 'post' on the first reply too soon. I've edited it with more info.


Oh of course! that makes perfect sense! obviously I will change the board in the IDE to reflect the lilypad, and not the Duemilanove, correct?

Thank you so much for your help :slight_smile:

That should work!


Thanks heaps, I will try it in a bit and post back.

I hadn't installed arduino on this new computer yet, so I went through the process and I can't get the program to communicate with the boards.

The RX flashes 3 times then nothing. after a timeout I get the classic

avrdude: stk500_getsync(): not in sync: resp=0x00

I tried installing the FTDI drivers that came with the arduino software, and the com port shows up in control panel (com 6).

I also tried installing the drivers directly from the FTDI website. Restarting the computer after every step of course to try and eliminate as many variables as possible.

I've also been googling this problem all afternoon and tried all suggestions such as hitting the reset button etc etc etc.

I'm just about to give up! I can't even tell if I can program the lilypad with connections I've made (they are connected correctly!)


If you disconnect the Lilypad and plug the ATMega328 back in the Duemilanove can you program it r do you have the same problem?

First thing I tried; I’m lead to beleive it is a computer problem or maybe the FTDI chip is somehow damaged.

I will try it on another PC and report back.

Okay so I made a mistake. I can program the duemilanove with this pc.

To clarify the connections are as follows

The VCC, GND, RESET, TX and RX pins are all connected from the Duemilanove board to the Lilypad's header.

It seems so simple.

What am I missing?

Does the Lilypad work if you connect vcc and ground (hopefully it has the default program of blinking the LED on pin 9). If that works, can you connect the reset line and see if the Duemilanove's reset button can reset the Lilypad?

The reset button on the duemilanove does not reset the lilypad. the lilypad's light just continues to blink. when I press the reset button on the lilypad itself the light goes off while I hold it in.

Question, should I be jumpering the connections on the duemilanove board from the ic socket directly or from the header pins? because I'm currently taking them from the header pins.

Definitely the header pins; no need to go to the IC socket and risk damage.

Where are you connecting reset? I just looked at the Lilypad schematic and it looks like it should go to the DTR header pin? If so, is there any way you can try to bypass the capacitor and resistor since the Duemilanove will already have it?

That was my thinking, I thought maybe the 2x resistor cap combo might be the cause.
Will try to figure it out and report back

Thanks again for your help!

okay I'm just going to order the FTDI adaptor...

Thanks very much for your help though, I really appreciate it