program of death

i uploaded a sketch that looped trough 4Kb and analogWrite-s it to the PWM PIN, after that the arduino refuses to be programmed, I tried burning the bootloader but I get errors aswell; I managed to do this to two arduino Diecimila that were working just fine prior to the last upload, any ideas?


  • the L led is flashing constantly

  • the error when trying to upload sketch:
    avrdude: stk500_recv(): programmer is not responding

  • the error when trying to burn bootloader using the parallel programmer:
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check

  • I did notice something strange, the L led seems to blink according to mouse movements plugged in the USB

  • the program (do not upload this sketch):
    unsigned char r2d2_4_sam = {

    unsigned int r2d2_4_sam_len = 4498;

void setup() {

void loop() {
for (int i = 0; i < r2d2_4_sam_len; i++) {
analogWrite(10, r2d2_4_sam*);*

  • delay(16);*
  • }*

Did the programmer work before the chip got clobbered. If you hadn’t tried it before then double check the suggestions on the bootloader page for things like giveio installed, polling of parallel port disabled etc.

I guess its too late to point out that the ATmega168 only has 1k of RAM.

Hi, thanks for the reply. I programmed the arduino using the USB cable, I made the programmer only after the recent truble, so I could not be 100% sure that the programmer was made correctly. I found a Windows machine I could try on (the outputs from the previous post where from Ubuntu Linux 7.10); applied the registry patch, installed giveio, and now I get:

avrdude: verification error, first mismatch at byte 0x3800 0x0c != 0xff avrdude: verification error; content mismatch

I'll order AVRISP mkII, and try again...

Hi, just as a followup, the AVRISP mkII helped,

thanks guys