Program will not upload to arduino

Hey All,

I am working on a hydroponic automation project for school. Specifically this one:

https://github.com/drolsen/DRO-Matic/wiki

I have put it all together and am attempting to upload and compile the code I cloned from github into visual studio, utilizing an arduino extension called vMicro.

Anyways I open the code in visual studio and attempt to compile, and I get 458 errors, of which they are either "cannot open source file.." and "identifier is undefined"..

As far as I know this should be a simple upload, because the code works. I am a newbie to visual studio 2019 and after I clone the code I don't know what to do to get it to compile.

Any help or guidance is much appreciated.

Have you tried using the Arduino IDE directly? The project says it supports it and that may be easier than VS

Yes, I could try and use the Arduino IDE separately.

So the question I have then is, when I open the Dro-matic.ino file and compiled. How come I get this error message?

Build options changed, rebuilding all
DROMatic:8:10: error: Adafruit_NeoPixel.h: No such file or directory

#include <Adafruit_NeoPixel.h>

^~~~~~~~~~~~~~~~~~~~~

compilation terminated.

exit status 1
Adafruit_NeoPixel.h: No such file or directory

this is the begginning of the dromatic.ino file:

/*

  • DROMatic.ino
  • DROMatic OS Core
  • Devin R. Olsen - July 4th, 2017
  • devin@devinrolsen.com
    */
    #include <Wire.h> //Include the software serial library for white sheild
    #include <Adafruit_NeoPixel.h>
    #include <LiquidCrystal.h> //lib for interfacing with LCD screen
    #include <SPI.h> //Suppoting lib for SD card
    #include <SD.h> //SD card API
    #include <StandardCplusplus.h> //STD
    #include <StandardCplusplus\vector> //Vectors
    #include <StandardCplusplus\ctime> //Time helper
    #include <ArduinoJson\ArduinoJson.h> //Arduno Json (aka epic)
    #include <DS3231.h> //Real time clock lib

Have you actually followed the GitHub instructions to download and install the Adafruit_NeoPixel library?

Willem.

Great thanks, your advice worked.

Unfortunately now I get this error message:

Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

DROMatic:13:10: error: StandardCplusplus\vector: No such file or directory

I followed the instructions and placed the cplusplus folder in the arduino library folder, yet it will not compile. How may I remedy this?

Have a look at this thread - it is about the same system, and problem.

It appears you need to use visual studio with arduino extensions to get that compiled and uploaded.

NB: Al the required libraries, including the Neopixel one, is actually included with the code.

Willem.

I read through the thread. I was wondering, I have arduino extensions and visual studio, I still am confused how they rectified the problem.

CP_Firmata.h:17: In file included from Adafruit_Circuit_Playground.h:25: from DROMatic.ino:9: from

CP_Boards.h: 746:2: error: #error "Please edit CP_Boards.h with a hardware abstraction for this board"

error "Please edit CP_Boards.h with a hardware abstraction for this board"

DROMatic.ino: 25:25: fatal error: src\Globals.h: No such file or directory

include "src\Globals.h" //All temp and PROGMEM global variables

compilation terminated Debug build failed for project 'DROMatic'

I am so close to uploading this I now get an error

Severity Code Description Project File Line Suppression State Suppression State
Error (active) E1696 cannot open source file “vcruntime.h” DROMatic C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\ucrt\corecrt.h 10

K I fixed the previous errors and now I am getting two more errors that I think are similar in nature but I am having problems locating the files…

#include <stdarg.h>

&

#include <stdbool.h>

both cannot open source file errors. I wonder where these are stored…