programer is not responding... urgent help!

I just got my Duemilenova. The IDE cannot connect with the board:

avrdude: stk500_recv(): programmer is not responding

I checked everything, the board and the port (Duemilenova328/tried both dev.tty and dev.csu usb serials), pressed the reset before uploading, then after uploading, still nothing, the "L" led keeps blinking. Also, switched off bluetooth. When I press the reset button, nothing happens. I use IDE 15 on Mac Os X 10.4.11. Should I send it back to the seller?

Also, how long and when should I press the reset button? What should happen when I press it shortly?

The board shows up in the System Profiler. I couldn't run the macosx_setup.command

Sorry about the lame question but how does macosx_setup.command work? Where can I find it?

Check your IDE setting on Tools -> Board. You should select "Arduino Duemilanove w/ ATmega328".

It's fine. Still nothing.

When and how should I reset? What should happen when I press the reset? When i press it nothing happens.

Why does the L led keeps blinking?

Try to set this in preferences.txt :

build.verbose = true
upload.verbose = true

On linux the file is located in “$HOME/.arduino/”. On Windows you can find it in “/arduino-0015/lib/”. Then start the IDE from a terminal window or with “run.bat” on windows. When you press “upload”, a lot of build messages will appear in the terminal. Watch out for these lines:

avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]

As soon as they appear release the reset button and it will upload. With just a little practice this works perfectly fine.

Not shure how to do this on mac... And again, why does the L-led keeps blinking? Is that normal? And where is the macosx_setup command?

why does the L-led keeps blinking? Is that normal?

Probably because the Blink program was uploaded in your chip before the shipment.

Have you tried to modify your upload speed setting

atmega328.upload.speed=57600

to

atmega328.upload.speed=19200

in your arduino/hardware/boards.txt file?

Whenever I try to upload, the RX led blinks once, then the IDE says "avrdude: stk500_recv(): programmer is not responding". Then the L led blinks every second.

New Arduinos are loaded with the “Blink” program, so this is normal.

As I don’t have a MAC, I wouldn’t know about that. I haven’t found the macosx_setup in the zip file for MACs, maybe it is not needed anymore.

To test if the serial connection to the Arduino board is working or not try this:

  • connect the Arduino board
  • open the IDE and select the correct serial port
  • activate the serial monitor
  • take a wire and plug it into the RX and TX pins on the Arduino board (top right, digital pins 0 and 1)
  • when you type in some text and press the send button, you should see an echo of it coming back

If that works the FTDI chip / driver is working properly.

Regarding the modifications of “preferences.txt”, Linux/MAC should be the same.
Just search for all present versions of the file and make the changes.

Tried it but didn't work. Thanks anyway!

  • when you type in some text and press the send button, you should see an echo of it coming back

It's working! Thanks! Not the uploading though:(

OK. So it's a bootloader specific problem.

When you press the reset button and release it, the L-LED should blink a short code of ON/OFF before the continuous 1s blinking. This code should show that a bootloader has been flashed to the chip. No code no bootloader.

Oh, and if you make modifications as suggested before like

atmega328.upload.speed=19200

you must always restart the Arduino IDE !

Madworm, thanks! Should I send it back to the seller? Is there a UK distributor who sells it whit the bootloader?

I’ll just send this board back then. Thanks for all your help guys!

Spent the whole night testing everything: the drivers and the serial port/FTDI chip work. When inserting a LED to the GND and input 13, it blinks. On the other hand the reset button doesn't do a thing. After pressing it the led keeps blinking, nothing changes. While uploading, I still get the same message:

avrdude: stk500_recv(): programmer is not responding

Is it possible that the board I got is just simply faulty?

If the reset button doesn't have any effect at all (even the L-LED continues blinking, while it is pressed), there's definitely something fishy. Before you go nuts, have a word with the seller.

If a MAC user should read this: Is there any history of auto-reset not working on MACs ?