Programmer is not responding (correctly)

Hi there,

I recently acquired an Arduino NG USB-board from PCB-Europe. I have a problem similar to the one described in this thread:

I’m using Windows XP Service Pack 2 and Arduino-007. I installed the drivers correctly and the device shows up in Device Manager. If I connect the board, the green LED lights up and the L, RX and TX-LEDS blink briefly. Then, after a delay of a couple of seconds, the L-LED starts blinking.

If I load the LED-blink-example in the Arduino-software, press the RESET-button and then click “Upload”, I get a “Programmer is not responding” error. I also tried clicking upload immediately before pressing RESET (or a couple of seconds before pressing RESET), but I either get a “Programmer not responding” or “Device is not responding correctly”.

I tried it numerous times, varying the time between pressing RESET and clicking Upload, but with no result.

After trying it a couple of times, I got this error in the Arduino-app:

Binary sketch size: 3676 bytes (of a 7168 byte maximum)

Error inside Serial.() Unknown Application









at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)

Error: Permission denied
→ /dev/com5

Could this be part of the problem?

Did you check the troubleshooting guide ( In particular, do you have ZoneAlarm or other firewall software running? Or a PDA sync app? When you reset the board, does the onboard "L" LED flicker quickly?

Yes, I have read the guide. If I reset the board, the L-LED blinks shortly, so I guess the bootloader is all right. I have Sunbelt Kerio Personal Firewall and BlueSoleil-drivers installed, but I always quit these processes before connecting the board and starting the Arduino software.

I tried again to upload the LED-Blink-program to the Arduino, but this time I always got the "[VP1] Device is not responding correctly"-error, except for once when I got the "Programmer not responding"-error. I also noticed, that just before I get the "Programmer not responding"-error, the RX-LED on the board blinks briefly. I'm not quite sure what this means; I guess it means that the board is communicating with the computer, but the computer doesn't detect it?

I also tried to connect the board to another computer, also running Windows XP SP2, but no firewall-, bluetooth- or sync-software (to eliminate the possibility that I didn't quit all the processes which are related to my firewall and bluetooth-app), but with exactly the same results as on my computer.

[edit]I also tried uploading some code to the Arduino on a freshly installed Windows 2000 machine. If I try to upload, the TX and RX-LED's both blink a couple of times, but each time I get the "Device is not responding correctly"-error. I'm currently installing Ubuntu Linux on my laptop, and I'll check out if I can get the Arduino to work in Linux. If that doesn't succeed either, could it be that my Arduino is damaged?[/edit]

[edit]I installed the Arduino-software under Ubuntu v6.10 and it starts correctly, but still no luck uploading programs. I get the "Programmer not responding"-error every time.[/edit]

Can you set upload.verbose in your preferences file ( to true and try uploading again? It should print some debugging output that could be useful in figuring out what's going wrong.

Ok. I changed the upload.verbose-line.

The first couple of times, the output was

Binary sketch size: 3674 bytes (of a 7168 byte maximum) uisp -v=4 -dpart=atmega8 -dprog=stk500 -dserial=/dev/ttyUSB0 -dspeed=19200 --upload if=/home/alfonsvh/Desktop/arduino-0007/examples/led_blink/applet/led_blink.hex

Transmit: { 0 [30] [20] } Receive: { . [00] } Receive: { . [00] } [VP 1] Device is not responding correctly.

I kept on trying, and once I got this output:

Binary sketch size: 3674 bytes (of a 7168 byte maximum) uisp -v=4 -dpart=atmega8 -dprog=stk500 -dserial=/dev/ttyUSB0 -dspeed=19200 --upload if=/home/alfonsvh/Desktop/arduino-0007/examples/led_blink/applet/led_blink.hex

Transmit: { 0 [30] [20] } Receive: { . [14] . [10] } Transmit: { B [42] p [70] . [00] . [00] . [01] . [01] . [01] . [01] . [02] . [ff] . [ff] . [ff] . [ff] . [00] @ [40] . [02] . [00] . [00] . [00] [20] . [00] [20] } Receive: { . [14] . [10] } Transmit: { A [41] . [82] [20] } Receive: { . [8a] } Receive: { . [89] . [10] } Transmit: { A [41] . [81] [20] } Receive: { . [14] . [01] . [10] } Transmit: { E [45] . [04] . [04] . [d7] . [a0] . [01] [20] } Receive: { . [14] . [10] } Transmit: { P [50] [20] } Receive: { . [14] . [10] } Transmit: { u [75] [20] } Receive: { . [14] . [1e] . [93] . [07] . [10] } Transmit: { Q [51] [20] } Receive: { . [14] . [10] } Vendor Code: 0x1e Part Family: 0x93 Part Number: 0x07 Atmel AVR ATmega8 is found. Page Write Enabled, size=64 FLASH Write Delay (t_wd_flash): 12500 us EEPROM Write Delay (t_wd_eeprom): 25000 us Transmit: { 0 [30] [20] } Receive: { . [00] . [fb] } Firmware Version: 1.137 [VP 1] Device is not responding correctly.

I only saw this type of output once; each time I try to upload again, I get:

Binary sketch size: 3674 bytes (of a 7168 byte maximum) uisp -v=4 -dpart=atmega8 -dprog=stk500 -dserial=/dev/ttyUSB0 -dspeed=19200 --upload if=/home/alfonsvh/Desktop/arduino-0007/examples/led_blink/applet/led_blink.hex

Transmit: { 0 [30] [20] } Programmer is not responding.

Any ideas?

It looks like something is flaky, not misconfigured. Make sure that the ATmega8 is firmly seated in the socket. Check that the Arduino board isn't resting on anything conductive. And if that doesn't help, I'm guessing the board is damaged.

I tried removing and re-seating the ATmega, but still with the same results.

If the board is damaged, do you think I could get a replacement?

Hmm... with the ATmega8, does the RX light flash before the L LED starts blinking at 3 HZ? If so, you've got the timing right, as the bootloader is listening for uploads when the LED is off.

Can you try setting the upload.verbose flag (in your preferences file) to true and post the output you get?

AlfonsVH: you should be able to. I would contact PCB-Europe and ask them.

Ok. I'll ask them.


I moved my post to

I contacted PCB-Europe and they're sending out a new board via UPS tomorrow.

Let's hope that that one functions correctly! ;D

I just received the new Arduino-board from PCB-Europe and this one works like a charm! :)