Programmer is not responding on Serial Arduino

we received a bunch of Arduino 2.0 Serial PCB boards (here at UCLA, thanks for sending these!). We have soldered the parts onto them and transfered the bootloader program onto the chip (we have tested the bootloader is on the chip by pressing the resest and the LED on pin 13 turns on). However we are unable to get the Arduino Software to export to the board. We get a programmer is not responding error (this is happening for both the PC and Mac). Also we have gotten the error device is not responding correctly as well. Is there something straightforward I am missing - i believe for the usb version there is a jumper that needs to be set is there something similar for the serial version which is not documented? any help in troubleshooting would be of great assistance (also we are using the Arduino 0002 Alpha IDE). Thanks

Hej,

did you set up the proper options on the IDE? Under the menu "tools" you should modify:

  • Serial port numer, to be the one you have plugged your board to

  • Serial port speed: this is the uploading speed, which is different for the bootloader version you are using. If you took the bootloader from the site:

http://arduino.berlios.de/cgi-bin/yabb/YaBB.cgi?board=swtrouble;action=display;num=1131573568

then your bootloader is running at 9600

/David

yes - on PC just gave com1 as option so used that on macs they tried both virtual ports also we tried all baud speeds (though we started with 19200) - anything else i missed?

mmm ... can you check if the transistors are soldered properly?

/David

Also, only serial ports that are available when the IDE starts will be shown in the menu. Make sure that the board is plugged in when you launch the Arduino IDE so that the correct serial port will be visible.

yes, tried all this - still no go - transistors solder looks good -i will try again with another board also i will recheck parts list to parts we ordered in case something is different... otherwise i am not sure...

Maybe you could take a close up picture of the board and post it?

/D

Hi guys.

It looks like we might be having a similar problem but with a USB board. The USB-to-serial drivers seem to be installed OK, and the serial port (on my PC somewhat surprisingly COM11) shows up in the IDE. An LED from pin 13 flashes when we press reset (and also every 10 seconds or so even if we don't - is this what it does when it's a virgin (i.e. never programmed) card?)

So the communication should be up, and the bootloader seems to be ok.

Problem: whenever we try to upload a program, the IDE tells us the card is not responding. We do see a brief flash on the TX LED when we try to upload, so there is something going on...

Checking the USB circuit with a multimeter there's a connection between pin 3 and 4, is this normal?

/Fredrik

Did you check the FAQ (http://arduino.berlios.de/index.php/Main/FAQ)? It has some suggestions for troubleshooting. In particular, try uploading your sketch with the serial.download_rate (in the preferences.txt file) at 9600 and at 19200.

Which error message do you get?

Which version of the IDE are you using? 0002 has some problems uploading that were fixed in 0003.

The flashing every 10 seconds or so of the LED on pin 13 is normal. Because there's no program on your board, the bootloader re-runs itself.

We just had a similar problem with about 30 boards for a class here in Vancouver. It's solved, and I think it was this: some of the boards were expecting to be programmed in 9600 baud (older bootloader versions), and some were expecting 19200.

The Ardunio 003 preferences.txt file defaults internally to 19200, unless you change it.

The solution on our end was to reprogram, using an STK-500 Atmel programmer, the older chips with the new Ardunio 003 bootloader that's included in the Arduino 003 package. Everything works great now!

PS: our reprogrammed chips come up with the message "Firmware version 1.18" in the Ardunio 003 window.

Hi there, I'm having trouble uploading to my card. When I do it at school on a PC or Mac it works perfectly, but when I get home to my PC it doesn't work. I'm using 0003 and a USB-serial adapter. In my device manager it says the device is working properly, but the IDE is saying "Programmer is not responding."

My Baud rate is 9600, port is COM1 (only option on PC) and as I said it works on both a Mac and PC at school. For some reason unbeknownst to me, all I get is 'not responding.' Very frustrating :( If anyone has any ideas, they'd be greatly appreciated.

Thanks

Whoops. I must have missed it, or it may have been due to a fresh install of my USB-serial drivers, but COM3 showed up and when I selected that everything worked perfectly.

Hi,

I had exactly the same problem as Fredrik Petersson. On two computers, XP and Mac OS X G4 with all drivers and stuff installed. On other computers it worked fine with the same installations. It seems that there is some problem when you use computers that have other software using Javas Serial communication installed wich is the only thing the both computers I did not work with had in common. Arduino did not work on the computers with different versions of Handy Cricket Software.

You're probably right about the conflict with the Java serial library. We're using an open-source serial library (RXTX) as a replacement for Sun's Java serial library (which doesn't work on the Mac). It's possible that Arduino picks up another Java serial library which conflicts with the one it comes with. What error message do you get? Do you see a comm.jar or jcl.jar or serial something in /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/lib/ext on the Mac (or in the respective folder on your PC)?

I only get the Programmer not Responding Error Message after seeing a brief flash on the TX LED . Even removing comm.jar, win32com.dll and deinstalling CricketLogo did not change the situation. I tried to figure what the CricketLogo installer does but there is no Source availible.

I just bought a USB Arduino board from Sparkfun in the US, and I'm having the same "programmer not responding" error. I've tried it on two different windows xp machines, on different USB ports (usually defaults to 5). I've tried changing the port and the baud rate in the IDE, I always press the reset button, I downloaded the latest USB driver. An LED connected between pin 13 and ground blinks rapidly (twice a second or so), which is faster than others reported - I assume this means the boot software on the Atmega chip is properly loaded, yes? What now? Thanks, Paul

Is there anything connected to pins 0 or 1?

Have you ever managed to upload a program to the board?

Nothing connected to pins 0 or 1, never been able to upload from either of my computers.

It's strange that you can see the individual blinks; it actually sounds slower than it should be. How many times does it blink?

It's possible that either you have an old version of the bootloader or your chip is configured to run slower than it should be. You could try changing the serial.download_rate in your preferences.txt file (in Documents and Settings\USERNAME\Application Data\Arduino - edit when Arduino is not running) to 9600, 4800, 2400, or 1200.

Also check if you have any overly aggressive anti-virus software or firewalls running. Or PDA sync applications, other microcontroller downloaders, etc. They sometimes conflict and block access to the USB-serial ports.