"Programmer is not responding" os x intel

It's that time again, I need to get Arduino working on a new platform (along with one hundred other things!). So I have two USB v2.0 boards that were fine on the prvious set-up (0003 on OS X 10.4.6 PPC).

I have the latest FTDI driver, and so my first step was to install the correct java extensions for RXTX. They come with the Processing distribution, this saves you compling from source for intel :http://processing.org/download/index.html.

Arduino IDE starts up and compiles fine. Whare I am now, is stuck with the dreaded "Programmer is not responding". I've tried the reset, download, download reset, reset 3 seconds etc dance routine, but no joy.

Out of curiosity I downloaded and installed the uisp tools, which lets you communicate with the Atmel chip from the command line, http://www.nongnu.org/uisp/. Low and behold I can download the programme on the Arduino board, ah reminds me of the good old days, when I could put stuff on it! Here's the command I ssued, and what I see:

tobie% uisp -dprog=dasa -dserial=/dev/tty.usbserial-000011FD -dpart=ATmega8 --download Atmel AVR ATmega8 is found. Downloading: flash S0080000666C617368E9 S113000000000000000000000000000000000000EC S113001000000000000000000000000000000000DC S113002000000000000000000000000000000000CC S113003000000000000000000000000000000000BC ... etc ...

So I can confirm the connection and hardware are fine, any other thoughts about what to try next would be great?

I'm back, and it's now working. This was acheived by edditing "serial.download_rate" in the preference file from 19200 to the lower rate of 9600.

This has been mentioned elseswhere, sorry to state the obvious!

hi, I’m back to continue my monologue!

I can confirm that “Programmer is not responding” problems have been solved for OS X Intel by paying attention to the value of serial.download_rate in the user’s preferences ( found in /Users/USERNAME/Library/Arduino/preferences.txt).

For Arduino v2.0 boards edit this line to:
serial.download_rate=9600

For Arduino NG boards edit this line to:
serial.download_rate= 19200

I’m not sure if this proves helpfull in your own situations, but this was the deal-breaker for me, as opposed to the reset-button-shuffle and other common fixes.

I’ll be back with other findings from the world of windows shortly.