"Programmer is not responding"

I have Arduino/Genuino uno board from the starter kit and am connecting it to my mac, which is up to date with its OS X version.

I am quite new to all this and am mostly in the dark trying to figure out what's happening.

SO my issue is that as soon as I connect my board to the computer with the green light the orange light also continuously starts blinking.
Initially I thought this was because the "blink" program is already uploaded. However even upon changing the time delay and re uploading does not make a difference. It constantly tells me that the programmer is not responding.

I even tried uploading the digital example sketch of blinking without delay. Ending up with the same result.

And all this time the orange light continued to blink and the green light was on.

Could anyone please suggest things I could do or identify what's happening and why?

Have you selected the correct board and com port?

it just worked.

Initially I was only receiving one option for the port, so I switched my programmer to USBasp and a new option popped up, which worked.

Thank you