programmer is not responding

I have a Keystudio 4wd car kit, which uses an Arduino Uno R3 board, . motor driver board, L289 Motor Shield, Bluetooth HC-06, LCD, Line Tracking Sensor, Ultrasonic Sensor and IR Receiver module.
I copied the program from the kit manual by hand, since the vendor download was deficient. I have problems with the LCD portion of the program, so I commented out all reference to the LCD. That resulted in a successful compile using the Arduino IDE.
The Arduino IDE confirms that my serial port is /dev/tty/ACMO

When I attempt to “upload” from the Arduino IDE “sketch” dropdown, I get the following output:

Arduino: 1.8.5 (Linux), Board: “Arduino/Genuino Uno”

Sketch uses 7080 bytes (21%) of program storage space. Maximum is 32256 bytes.
Global variables use 574 bytes (28%) of dynamic memory, leaving 1474 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

Please advise.

I neglected to say that the Uno board has a blinking yellow light, and a red power light lit. I tried pressing the Uno reset button prior to trying to upload. Still no joy.

What do dmesg and lsusb say when you connect/disconnect the Uno?

The behaviour that you describe in the second post is normal: Arduinos come with the blink sketch preloaded.

PS I'm no longer a 'real' Linux user so might not be able to help further.