programmer not responding, other issues, a wrap-up

I figured after the problems I had it would be a good idea to post my experiences.

1) I was given an old board by a neighbor, serial, no version numbers on the pcb. 2) When powered up it would blink 3 slow blinks. 3) No matter what baud rate I put in the preferences file, I would get either the "[vp 1] device not responding correctly" or the "programmer not responding error". 4) I have been using an "IOGear" Prolific chipset based USBtoSerial converter as my serial port on an Intel Mac.

I use linux at my office (Fedora Core 5) and tried getting everything going there. It was not easy, but I did manage to get the GUI up without errors. And at that point was able to upload a program to the board at 9600 baud. As soon as I upoaded the program I (rashly) figured I should update the bootloader so that I wouldn't have to worry about the 9600 baud requirement again. That may have worked successfully, however, the board still blinked 3 times on power up/reset, and I never got past the "programmer not responding" error again (yes, I switched the prefs file to 19200 afterward). The output of the bootloader burn is at the bottom of this post.

So I got a db25 connector, and back at home, soldered up the resistors and a header to my board. Voila, was able to re-program the bootloader with only the UISP package on an old linux system (uisp -dprog=dapa -dpart=ATmega8 if=prog.hex -dlpt=0x378 --erase --upload, worked perfectly, check that your parallel port is using 378, by running "grep lp /proc/ioports"). Once the new bootloader was installed, the board only blinks ONCE (or possibly more times, but very quickly).

After the bootloader was installed, I fired up the mac, Bingo- loaded a test program. Change program, try to load it, failed with "programmer not responding". Try again 20 times, still only get programmer not responding.

So the real discovery is that if you are using a USB to Serial converter, either the driver, or the Java RXTX code may be flakey. If I unplug and replug the serial converter each time I upload, success. Every time. I tested maybe 25 times, every time successful, so long as the converter is unplugged and replugged.

If you're having the same programmer not responding issues: 1) get the latest bootloader installed. 2) get the lastest (0005) build of the software. 3) unplug and replug your usb serial port (if you use one). 4) click the upload to board button while holding the board reset button, wait 1 second and release the reset button on the board. 5) for any subsequent downloads to the board, unplug and replug your usb serial port first.

The RPMS+src packages I used for the linux install on FC5 are posted to:

I don't have a fast connection, fyi.


My bootloader burn output (hints that maybe the fourth step failed, possibly because the baud rate is changed after the flash is uploaded?):

[root@knud linux]# ./ Experimental: JNI_OnLoad called.

Stable Library

Native lib Version = RXTX-2.1-7 Java lib Version = RXTX-2.1-7

Atmel AVR ATmega8 is found. Firmware Version: 1.18 Firmware Version: 1.18

Lock Bits set to 0xff Atmel AVR ATmega8 is found. Firmware Version: 1.18 Firmware Version: 1.18

Fuse Low Byte set to 0xdf

Fuse High Byte set to 0xca Atmel AVR ATmega8 is found. Uploading: flash Firmware Version: 1.18 Firmware Version: 1.18 Programmer is not responding. Programmer is not responding.