Programmer not responding

Hello people,

I've made a little buzzer system with my Arduino Uno few weeks ago, and it worked fine, until the day that i needed it, when i turned it on, and tested a little on the buzzer and poof, it died, and when i try to upload the blink sketch to see whether the board is still working, the programmer not responding problem showed up.

Prior to that, while I was testing the buzzers, one of the transistors burnt out of nowhere, and then when i did the upload, it failed, so I suspect that it has something to do with the transistor. Can anybody please help me troubleshoot this?

This is the circuit diagram showing how the transistor was connected.

Thanks. :)

No resistors?

ah, i think i missed that. so no, i wasn’t using any resistors for the transistor

You will need a current limiting resistor on the transistor base. You may also need a current limiting resistor for the buzzer.

Alright, i'll take note next time. But does that mean my Arduino is probably dead?

The processor is very likely toast. The rest of the board have survived. Start with a loop-back test.

So I did that and the message didn't echo. so the processor is dead? How can I replace it or I need to get a new Arduino?

The processor may or may not be OK.

The USB-to-serial converter is not OK. If the board uses an Atmel processor for conversion (like on an Uno) it is possible that reflashing the firmware may resolve the problem.

Er. To be frank I don't really understand what you've said, so mind explaining it a bit further and pointing me in the right direction?

What board are you using?

I'm using an Arduino Uno with ATMEL processor on it

Do you have a second working board of any kind? Do you have a "programmer" like a USBtinyISP?

Nop, I dont have any. But if I really need it I think I'll be able to borrow an Arduino Mega from my friend.

You won't need a second board / programmer. Sort about that. Instructions for reflashing the firmware...

http://arduino.cc/en/Hacking/DFUProgramming8U2

I've just tried it step by step like how it was written in the guide, but it failed when I do "sudo dfu-programmer erase". It says "no device present".

The only thing left is to try to reflash the firmware using your friend's Mega configured as a "programmer". I may be able to help you until you reach the point of actually reflashing the firmware; the avrdude command to execute. Unless someone else steps in to help, at that point you will be on your own.

I suggest first spending some time with Google; you may be able to locate detailed instructions... https://www.google.com/search?q=atmega8u2+uno+firmware+avrdude

Bear in mind that your board and/or processor may be toast. After reflashing the firmware your board may still be unusable.

Alright then. I'll see if I can borrow his Mega and I'll come back to this thread then. Anyway, thank you very much for the guidance. :)