Programming Arduino Uno with FTDI breakout

Hi there,

I somehow destroyed my USB connector on my Arduino Uno (diffrent post). Now I bought an FTDI break out board to get the chance to reuse the Uno again. So far I connected the cable as follows:


5V -> 5V
TXD ->RX (D0)
RXD ->TX (D1
DTR ->Reset

is this the right order?

then I started IAE and tried to upload the blink programm. After 10 times this error messages was generated:

Arduino: 1.6.9 (Windows 10), Board: "Arduino/Genuino Uno"

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean,
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Portable Programme\arduino-1.6.9\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x2e
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x2e

avrdude done. Thank you.

what could be the problem? I went through the troubleshooting guide and everything looks fine (driver, port,cable etc)

Thanks for any hint!

I figured out by myself. I found a connection with which I could upload scatches to my arduino.


CTS ->GND not connected!
5V -> 5V
TXD ->RX (D0)
RXD ->TX (D1
DTR -> Reset GND
during upload the auto-reset-function is not working, though you need to press the reset button on the arduino. I didn't figure out when exactly the button needs to be pushed. For me it worked well when I pushed the reset button when the RX-Diode on the FTDI-break out is blinking. By the way the wireconnection worked as well for the arduino pro mini.

OR: DTR -> 100nanoFahrrad capacitor -> RESET (on Arduino) then the auto-reset function is given!!

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:


:slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:

Well done.
Helped me out as well.
I had a bricked Nano and a suspect FTDI board.
Tried it with a new Nano and the cheapo FTDI. Once I'd figured out you need the FTDI port selected, not the Nano, it worked a treat using the click Upload and press reset straightaway method. So FTDI working, now to try the bricked Nano, but not optimistic.
Whilst researching this, I came across the counterfeit FTDI chips and driver issue - this is where FTDI apparently issued a driver that bricks counterfeit FTDI chips. My cheapo was laser engraved on the chip and was coming up with 2.10 driver on Control Panel. 2.10 was the last driver issue that didn't mess the counterfeits. So I took a chance and upgraded from 2.10 to 2.12.28. No smoke yet so I guess the cheapo board has a genuine chip on it.