Programming the ATmega1284P-PU [SOLVED]

What I'm trying to do:

Upload the basic blink code using a Genuino uno that runs on a ATmega328P; as a ISP to a ATmega1284P-PU.

Ive got the bootloader all burnt on the chip using Nick Gammon's method, but I can upload the code using his method because I don't have the SD card breakout board, so I just used the Arduino ISP code but when it comes to uploading I get this message: avrdude:

Expected signature for ATMEGA1284P is 1E 97 05 Double check chip, or use -F to override this check.

So I enable the verbose during upload and it says: (I thought this is the most important bit.)

Reading | avrdude: Send: u [75] [20] avrdude: Recv: . [14] . [1e] . [95] . [0f] . [10]

############################################ | 100% 0.00s

avrdude: Device signature = 0x1e950f avrdude: Expected signature for ATMEGA1284P is 1E 97 05 Double check chip, or use -F to override this check. avrdude: Send: Q [51] [20] avrdude: Recv: . [14] avrdude: Recv: . [10]

avrdude done. Thank you.

Now I understand that 0x 1E 97 05 is for ATmega1284P 0x 1E 97 06 is for ATmega1284 0x 1E 95 0F is for ATmega328P

Also when I used Gammon's method of burning the bootloader it even said that the signature is 0x 1E 97 05, so is this avrdude just stating the ISP's signature or does avrdude or the ISP think that that is the ATmega1284P's signature.

Any help would be much appreciated.

How did you disable auto-reset?

[quote author=Coding Badly link=msg=2710151 date=1460565475] How did you disable auto-reset?

[/quote]

If you mean connecting the chip reset pin to the arduino's digital pin 10 then thats what I have done if not then I'm not sure.

DTYlan: If you mean connecting the chip reset pin to the arduino's digital pin 10

No.

http://www.google.com/search?q=arduino+auto+reset

The first hit looks promising. Pay close attention to the bit about a capacitor.

Right, I had a look at http://playground.arduino.cc/Main/DisablingAutoResetOnSerialConnection and I placed the 10uF cap in place which I actually forgot about and when I did that I get:
Binary sketch size: 1,196 bytes (of a 130,048 byte maximum)
C:\Users\Dylan\Desktop\arduino-1.0.5-r2\hardware/tools/avr/bin/avrdude -CC:\Users\Dylan\Desktop\arduino-1.0.5-r2\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega1284p -carduino -P\.\COM3 -b115200 -D -Uflash:w:C:\Users\Dylan\AppData\Local\Temp\build6513307125199075873.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Users\Dylan\Desktop\arduino-1.0.5-r2\hardware/tools/avr/etc/avrdude.conf”

Using Port : \.\COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you. <–(cheeky)

Overriding Baud Rate : 115200

Is that the correct baud rate for the ArduinoISP sketch?

[quote author=Coding Badly link=msg=2710241 date=1460568462] Is that the correct baud rate for the ArduinoISP sketch?

[/quote]

I think so, If there was an option I could find on the IDE ver 1.0.5 to change it I would try a different baud rate.

(deleted)

Isn't ArduinoISP 19200 baud?

That is the way it is delivered... https://github.com/arduino/Arduino/blob/8385aedc642d6cd76b50ac5167307121007e5045/build/shared/examples/11.ArduinoISP/ArduinoISP/ArduinoISP.ino#L140-L146

Baud rate is correct in programmers.txt... https://github.com/arduino/Arduino/blob/8385aedc642d6cd76b50ac5167307121007e5045/hardware/arduino/avr/programmers.txt#L38-L47

Right, I would like to thank everyone who has helped me.

The way I did it was copying: C:\Users\Dylan\Desktop\arduino-1.0.5-r2\hardware/tools/avr/bin/avrdude -CC:\Users\Dylan\Desktop\arduino-1.0.5-r2\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega1284p -carduino -P\.\COM3 -b115200 -D -Uflash:w:C:\Users\Dylan\AppData\Local\Temp\build6513307125199075873.tmp\Blink.cpp.hex:i

and I changed -b115200 to -b19200 and opened CMD.exe and ran it through that and hay ho it works and I have the blink code running right in front of me.