what board should I select in__Tools>board If i am using roboduino atmega 8 based on arduino diecimila__

arduino diecimila would be my guess. Have you tried it ?

I have tried the third option arduino diecimila and deumilanove w/ atmega 168 and also tried the last option with atmega 8,
but after uploading it i am finding some orange text. I don't exactly remember what it says , but I remember few saying 'not in sync'.

I found this

The Roboduino is a microcontroller board based on the ATmega8. It is completely compatible with Arduino Diecimila.

on this site

Is that the board that you have ?

Yes, I have the same board.

So, what does happen if you select Diecimila ?
Does it compile ?
Does it upload ?
Does it run ?

it compiles and uploads but the code does not run on my board after uploading

It's time that you uploaded your code, don't you think ?
What should the code do ?

First, I tried blink in examples , I found that led on pin 13 was blinking even before the code was uploaded(when I first connected arduino board to my computer). All leds on the board were red including power. Whichever board I select in the software, I am still getting that orange text.
(Doubt: Or , is there any other programming language for my board?????).

What exactly does the error text say ?
I presume that a COM port exists for the board when it is plugged in (check in Windows Device Manager) and that you have selected the correct COM port in the IDE

If you are using a Mac or Linux then I don't know where you would check the creation of a COM port but there will be an equivalent to Windows I am sure.

i am using window's.
The error says: avrdude: stk500_getsync(): not in sync: resp=0x00

That error indicates that the Arduino board cannot communicate with the PC to upload the compiled code. If you put the text into Google you will get hundreds of matches because there are many and various reasons for it happening.

To recap
A serial port is created when you plug in the Arduino and is visible in Device Manager. It should disappear when you unplug the Arduino
You have that COM port selected in the IDE
You have selected Diecimila as the board type in the IDE

Is that correct ?

I feel that the board I have is atmega8.
And in the environment there is no diecimila with atmega option.

Is it true????????

Have you got the drivers installed that are available from the page I gave a link to in my reply #3 ?

Do you mean Software Reference Tutorials Driver????

These reached from the page I previously posted a link to.

Can you please guide me (give me instructions) as I am new to arduino (how to use my board) and about the driver software to be done in windows 7 ?

Can you also please tell what will happen after installing the drivers into windows 7

I downloaded the software . It's working well. Thanks a lot!!!!. The port I got is COM 10-11 with arduino NG or older w/atmega8.
Can you please send me a starter robot tutorial to work with?. Once again Thanks a lot!!!!. :slight_smile: :slight_smile: :slight_smile: