Programs do not seem to run but kinda do...

Hello,

New to the Arduino world, exciting stuff!

I have a Diecemilia/328 board that does not seem to work properly and I am beginning to think it is fried but have a bit of hope.

  • I can upload sketches to the board with no problems...

  • The "blink" LED sketch does nothing with a built in LED or a plugged-in on

  • Other sketches using output pins do not seem to work either

  • I ran this "hello world"/serial test sketch found here: http://www.ladyada.net/learn/arduino/lesson4.html and it did work as it should (serial port returned "hello world" text)..

any ideas what's going on? outputs are fried?

thanks in advance!

update:

I just loaded this sketch and connected a potentiometer to digital input 0 and it worked so now I am thinking the digital outs are fried?

The circuit:

  • potentiometer connected to analog pin 0. Center pin of the potentiometer goes to the analog pin. side pins of the potentiometer go to +5V and ground

created over and over again by Tom Igoe and everyone who's ever used Arduino

*/

void setup() { Serial.begin(9600); }

void loop() { // read the analog input into a variable: int analogValue = analogRead(0); // print the result: Serial.println(analogValue); // wait 10 milliseconds for the analog-to-digital converter // to settle after the last reading: delay(10); }

Sounds like you're not initiating your outputs with pinMode().

Are you using

void setup() {
pinMode(13, OUTPUT);
digitalWrite(13, HIGH);
}

void loop() {
}

?

Try that, and tell me if the LED on pin 13 lights up.

thanks for your quick reply!

no dice... nothing with the built-in LEd or one plugged in.

Big Edit:

Alright, so i tried your code with all the different digital outputs... good news is they pretty much all seem to be working with the exception of digital outs 8.9 and 13...

for DI 13, the program loads fine but does nothing...

For DIs 8 & 9, when I got to upload the sketch it returns this error: error: invalid digit "8" in octal constan

error: invalid digit "8" in octal constant

If you post your Sketch, I suspect someone will spot the problem.

Are you specifying the value as 08? if so, the leading 0 tells the compiler that the number is octal, and octal digits range from 0 to 7.

ahh-ha... that makes sense on that front...

either way, the outputs seems to all be working except for 13, which is kinda funny since that's the one that is supposed to be used for testing... I am not too concerned at this point, I guess they just needed to be "kicked on" somehow and that must have happened..

now i need to get my stepper turning instead of just vibrating like crazy!