Project 13-Touchy-feely lamp : Can´t put the CapacitiveSensor Libraries to work


I have search on many forums which adressed to similar problems as mine: how to put the libraries "CapacitiveSensor" to work, but none has helped me.

I downloaded it and put it on the folder Arduino->Sketch->libraries , having created this folder like they told to do on page 137 of the Starter kit book.

But as I compiled the CapacitiveSensorSketch it gave me a error similar to the one of this forum :

Also a similar error happened on the sketch designed for Touchy-feely lamp project .

I downloaded the other libraries folder someone gave on that same forum, but the same problem continued to happen.

I changed the name to "CapacitiveSensor" (as suggested on this forum and even extra added the librarie on the option on Arduino Compiler Sketch->Add Library and still the same problems.

Can someone help me here, please?

Thank you for the attention.


What is your directory structure for the libraries?

Is there 2 library directories in the CapacitiveSensor pathname??

If so try moving the CapacitiveSensor directory up to the first library directory.

Worked for me.


The Download zip file has the following directory structures ....




whereas (on my linux pc)

In my preferences for Sketchbook location I have ... /home/username/Documents/Ardunio (check yours)

thus the Arduino library directory is


If I unzip the d/l file into my Arduino library directory, the zip directory structure is appended to the arduino libray directory, thus creating the following ...


note the 2 libraries directories.

I simply moved the CapacitiveSensor directory into the first libraries directory.

And all was ok ! :D